I have installed VMWare 14.0 on Ubuntu 16.04 (both 64 bit versions) following instructions here.

I made a new virtual machine to install a Windows 7 - 64 bit, but when I want to power it on to install my ISO file, the workstation says:

Unable to change virtual machine power state: Disconnected from virtual machine.

There is no hard disk issue; I have 59G available and this VM needs maximum 40G hard disk.

What is wrong or where can I find the cause?


I have tried sudo /usr/bin/vmware-modconfig --console --install-all; this is what I've got at the end:

Starting VMware services:
   Virtual machine monitor                                            failed
   Virtual machine communication interface                             done
   VM communication interface socket family                            done
   Blocking file system                                                done
   Virtual ethernet                                                   failed
   VMware Authentication Daemon                                        done
Unable to start services

3 Answers 3


I have the same problem with a current Win 10 virtual machine that works fine in version 12 of the player.

Running the following at the command line fixed the problem and allowed the VM to start normally.

sudo /usr/bin/vmware-modconfig --console --install-all


try uninstall and reinstall vmware again. you can uninstall using:

sudo vmware-installer --uninstall-product vmware-workstation


I solved the issue by changing boot type in BIOS settings of my computer.

The boot type was set to Windows 7 there; I changed that to Other OS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.