0

I hope someone can help me here. I have spent quite a time to figure this out but.. no luck yet. I am very beginner for Ubuntu/Linux. So I found instruction for phpbrew somewhere and successfully installed it, but I can't install old php version. To install old php, I used as $ phpbrew install 5.3.1 +default And I get errors below. Even if I search those errors on Google, I could not find any solutions. Could anyone give me some tips how I can install old php version? I have a project that targets the php version so I really need to install on my local machine to develop some application.

the error I got:

===> Checking patches...
Checking patch for php5.3.29 multi-sapi patch.
Checking patch for php5.3.x on 64bit machine when intl is enabled.
3 changes patched.
Checking patch for openssl dso linking patch
===> Building...
Error: Make failed:
The last 5 lines in the log file:
ext/intl/grapheme/grapheme_string.o:(.rodata+0x8): undefined reference to `grapheme_extract_bytecount_iter'

ext/intl/grapheme/grapheme_string.o:(.rodata+0x10): undefined reference to `grapheme_extract_charcount_iter'

collect2: error: ld returned 1 exit status

Makefile:244: recipe for target 'sapi/cgi/php-cgi' failed

make: *** [sapi/cgi/php-cgi] Error 1

Please checkout the build log file for more details:
     tail /home/buntu/.phpbrew/build/php-5.3.1/build.log

===== build.log details below (/home/buntu/.phpbrew/build/php-5.3.1/build.log)
/home/buntu/.phpbrew/build/php-5.3.1/ext/openssl/openssl.c:917: undefined reference to `EVP_md2'
ext/openssl/xp_ssl.o: In function `php_openssl_setup_crypto':
/home/buntu/.phpbrew/build/php-5.3.1/ext/openssl/xp_ssl.c:324: undefined reference to `SSLv2_client_method'
/home/buntu/.phpbrew/build/php-5.3.1/ext/openssl/xp_ssl.c:344: undefined reference to `SSLv2_server_method'
ext/intl/grapheme/grapheme_string.o:(.rodata+0x0): undefined reference to `grapheme_extract_count_iter'
ext/intl/grapheme/grapheme_string.o:(.rodata+0x8): undefined reference to `grapheme_extract_bytecount_iter'
ext/intl/grapheme/grapheme_string.o:(.rodata+0x10): undefined reference to `grapheme_extract_charcount_iter'
collect2: error: ld returned 1 exit status
Makefile:244: recipe for target 'sapi/cgi/php-cgi' failed
make: *** [sapi/cgi/php-cgi] Error 1
0

You can install PHP as a part of XAMPP package. The XAMPP contains Apache, PHP, MySQL and Perl. The XAMPP 1.7.7 is the most updated XAMPP with PHP version 5.3.

You can find more information on Stackoverflow

0

If you don't need openssl just omit it from build

phpbrew install 5.3.1 +default-openssl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.