10

I have a dell XP’s 9560 laptop and I want to install an Ubuntu distribution alongside windows 10. I tried a lot so far to install it but I can’t see any partitions. I figured out that the problem is that I have raid on from Sata configuration from bios. I don’t want to disable this because it will mean reinstalling my windows.

Can I install a dual boot with Ubuntu with raid on without any modification?

Thanks

  • Win10 cn be converted to AHCI without reinstalling. All that is required is getting the AHCI drivers installed. – ravery Oct 8 '17 at 16:34
14

You don't need to reinstall Windows...

Some folks have found the 2nd choice that I provide easier to do...

Make sure to have a backup of your important Windows files!

You've got a single SSD set up in RAID mode, and the Ubuntu installer won't recognize your SSD until you switch your disk setting in the BIOS from RAID to AHCI.

Making that switch comes with some problems though, as Windows will no longer boot.

Choice #1: Looking at this article https://samnicholls.net/2016/01/14/how-to-switch-sata-raid-to-ahci-windows-10-xps-13/ will show you how to make the change without having to reinstall Windows.

  • Boot to Windows with your current SATA controller configuration
  • Open Device Manager
  • Expand Storage Controllers and identify the Intel SATA RAID Controller
  • View properties of the identified controller
  • On the Driver tab, click the Update driver… button
  • Browse my computer…, Let me pick…
  • Uncheck Show compatible hardware
  • Select Microsoft as manufacturer
  • Select Microsoft Storage Spaces Controller as model #
  • Accept that Windows cannot confirm that this driver is compatible
  • Save changes, reboot to BIOS and change RAID SATA Controller to AHCI
  • Save changes and reboot normally, hopefully to Windows

Now you should be able to install Ubuntu in a dual-boot configuration.

Choice #2: See http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

  • Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  • If you don’t see Command Prompt listed, it’s because you have already been updated to a later version of Windows. If so, use this method instead to get to the Command Prompt:
    • Click the Start Button and type cmd
    • Right-click the result and select Run as administrator
  • Type this command and press ENTER: bcdedit /set {current} safeboot minimal
    • If this command does not work for you, try bcdedit /set safeboot minimal
  • Restart the computer and enter BIOS Setup (the key to press varies between systems).
  • Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  • Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  • Right-click the Windows Start Menu once more. Choose Command Prompt (Admin)
  • Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
    • If you had to try the alternate command above, you will likely need to do so here also: bcdedit /deletevalue safeboot
  • Reboot once more and Windows will automatically start with AHCI drivers enabled.
  • Perfect. I wish I'd found this answer 4 hours ago. – DevDonkey Jun 10 '18 at 7:32
  • 2
    I followed the first method, and then I could no longer boot Windows in neither AHCI nor the RAID mode. I got into the repair menu, where I clicked my way to restart in safe mode (requires a key for the crypted partition). I looked into the driver settings again, but did not change anything, it is still "Microsoft Storage Spaces Controller" (no idea what "as model3" means, I don't find such an option). Now it seems to work. – donquixote Jan 11 at 3:34
  • I wanted to say thank you so very much. This answer helped. I had to combine steps 1 and 2 I installed the driver and then in step 2 I couldn't run the /deletevalue command. I could log in but it showed only a blank screen. So I fixed it by running the perennial ctrl+alt+del which allowed me to open a task manager and from there run a task msconfig where I could set it back to normal boot. Now I finally have a working dual boot in a Dell G3. I hope installing drivers will not be a pain. – Zloy Smiertniy Jan 14 at 23:38
  • For future reference, I advise doing method 1 and 2 together. In my case, on a DELL XPS 13 9370 with preinstalled windows, first method didn't work but going in safe mode after installing the drivers did the trick. – Some progammer Mar 25 at 14:34
  • 1
    @GeorgeUdosen Glad it worked for you. Please remember to vote for the answer. Thanks! – heynnema Jun 15 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.