I created a presentation and started editing it, and almost immediately everything started hanging. No mouse, no Ctrl-Alt-Fx for virtual consoles, system doesn't respond. After waiting for a few minutes, the system briefly jumped to the F1 virtual console I requested, but then I got a Unity login screen, so maybe X had crashed and restarted.

Ever since then the touchpad doesn't work. I tried rebooting, "synclient TouchpadOff=0" (it's set to 2 otherwise) and touchpad-inicator - which also has an effect on the TouchpadOff variable - but nothing helps. I tried to follow some X package installation advice, but the package cannot be installed due to errors. xinput lists the Touchpad:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=14   [slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse                id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Lenovo EasyCamera                         id=11   [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]

Anyone who went through this before? Should I completely reinstall the system?

Thank you.


I tried what many recommended and installed "xserver-xorg-input-synaptics", and boy did that make things worse by shutting off my keyboard too (external USB keyboard was ignored as well), so the system became completely unusable.

After struggling with the Ubuntu recovery options for some time, I was eventually dropped into a root virtual console some failsafe-booted system and could fix my problems with:

apt-get install --reinstall ubuntu-desktop

Now everything is working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.