0

I tried to install Ubuntu on my Surface 3 tablet, and it went thru the install pretty good, but when it booted up from the install, it had this message "please unlock disk mmcblk0p3_crypt". I can't type anything, or select anything. I've tried powering off and booting up again, but no luck. What does this message mean, and how can I proceed?

  • Have you tried the Kernel packages for Microsoft Surface devices? – Jaime Oct 8 '17 at 13:04
  • Thanks for the reply. No I haven't tried that, thanks for pointing me in that direction. I'm totally new to Linux, that's why I want to try it, and learn :). I will try it and comment if it works. – Roger Oct 9 '17 at 0:41
  • How do I know which one to download? Also, is it normal to have a bunch of errors generated after you select which OS to boot into? I select "ubuntu" and then some errors are generated, and then it shows what I wrote in my original question-please unlock disk... – Roger Oct 9 '17 at 0:52
  • Did you install the Ubuntu selecting the encrypt filesystem option ? -- If you did it, You can reinstall the ubuntu without that option. – Jaime Oct 9 '17 at 19:39
0

I do not have a Surface 3, but there are many pages showing some instructions may help you.

how can I proceed?

  1. If you have installed ubuntu with disk encryption, re-install the ubuntu disabling the disk encryption.

  2. When your ubuntu boots the first time, install the linux kernel packages for Surface.

    sudo add-apt-repository ppa:tigerite/kernel
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install linux-surface
    sudo apt-get dist-upgrade
    
  • Thanks man, it worked. I'm posting this from it right now. The main problem was the disk encryption, I still am working at installing the kernel package – Roger Oct 10 '17 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.