1

I have managed to install the correct drivers for my Nvidia Geforce 940MX on my asus i5 laptop. When I open NVIDIA X Server Settings, I have the option to choose between my two GPUs (NVIDIA (Performance Mode); Intel (Power Saving Mode)) but when I change from intel to Nvidia and vice versa. It asks me to log out to apply the changes. When I log out and back in again, I get a blank screen for a second, and then am returned to the gnome login screen, every time I try to log in. I have tried reinstalling the drivers and flushing all Nvidia software but this has had no effect. When I reboot, however, the GPU changes. So this leads me to believe that the problem lies with gdm3 and gnome-shell.

I am running ubuntu gnome 17.04 with:

  • GNOME Shell 3.24.2
  • GDM 3.24.1
  • Nvidia binary driver - version 375.66 from nvidia-375
  • Processor microcode firmware for intel cpus from intel-microcode

I have tried "service gdm restart" from a non-gui tty and this makes no difference.

Any help will be appreciated especially considering Ubuntu's move away from unity to gnome shell ;)

0

This is probably related with this bug in GDM.

Anyway, the best workaround in Ubuntu GNOME is to change GDM to lightdm (in fact, lightdm in Ubuntu is way better than gdm, imho):

  1. Install lightdm

    sudo apt install lightdm

  2. Switch the DE to lightdm

    sudo dpkg-reconfigure lightdm

  3. Reboot

    sudo reboot

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.