System has two hard disks: 160GB SSD, which is the boot disk and 500GB RAID1 HDD.

I have Windows 7 Ultimate 64-bit installed as the main OS on the SSD. I don't want to touch or modify this drive.

The 500GB RAID1 drive had one partition: 1 primary NTFS partition for storage of stuff I want to access from Windows, and then about 200GB of unallocated space.

I ran the 11.10 installer, selected the "just install the stuff" option (the first one, I forget what it's called), and it installed it in the unallocated space, creating two primary partitions: one ~200GB ext4 partition for Ubuntu itself and another 12GB primary partition for the swap file (same size as RAM I have).

Problem is that Grub didn't install to the MBR on the boot disk (the SSD) so I have no way of starting Ubuntu that doesn't involve BIOS shenanigans. I am kind of apprehensive about manually installing Grub into the MBR of the boot disk myself so any guidance regarding if that's even what I need to do would be great.

FYI, I tried re-installing specifying everything manually, including setting the ~200GB ext4 partition to be the / mount point and telling the installer to install the bootloader on /dev/sda1 (I think, perhaps is was /dev/sda, I forget, exactly), and that didn't work, either.


I recommend you install GRUB into the Master Boot Record of the second hard disk you are installing Ubuntu on and configure your bios to boot that hard drive first, GRUB will detect your Windows install on the SSD and include it allowing you to choose either operating system on start up.

When you install ubuntu ensure you select /dev/sdb as the destination for GRUB.

  • I don't think that will work, Windows will be borked because of the drive letter reassignments (C: and D: will swap and all of a sudden Windows will be on D: and looking for stuff on C:, including Windows itself). – Robert C. Barth Jan 18 '12 at 15:53
  • Have a good read through the info on the site link - Windows will not change drive letter assignments. Trust me it will work - I dual boot my desktop computer this way and have done so since 8.10. – Mark Rooney Jan 19 '12 at 2:46
  • Link appears dead... – Robert C. Barth Jan 19 '12 at 17:43
  • 1
    Must be SOPA at work already!! I re-read your question and realised you have a RAID disk you are installing to, because of this you need to install GRUB to both RAID partitions. Have a look at the answers on this previous question askubuntu.com/questions/43036/… – Mark Rooney Jan 20 '12 at 9:21
  • OK, I did this, and it worked right up until the point where I booted into Ubuntu and installed a bunch of updates. There was an update for the kernel to 3.0.0-15 (from 3.0.0-12). Now I can't boot again. I can boot the older version (3.0.0-12) just fine from the Grub menu. I looked at the grub.cfg in /boot/grub and it's identical between the two except for the version number, and the symbolic link in the root of the drive as well as the binaries they point to are all there. This is driving me nuts now. – Robert C. Barth Jan 26 '12 at 22:55

Okay, so I found this program, EasyBCD, which will sort out the problem for you. It is free for non-commercial use, just see the link at the bottom of the page. There is a real easy walk-through for most OS setups. Here's the Ubuntu one.

This is a really nice solution. I have used it and it worked perfectly. Hope this will help you if you have the same problem

  • I ended up buying an additional disk, making it the boot drive, installing GRUB and Ubuntu on it, and everything worked fine. The "problem" was most likely that the second disk was a RAID1 mirror set and upon updating, GRUB didn't re-set the fake raid drivers or whatever like it does when it first installs. – Robert C. Barth Apr 25 '12 at 16:52
  • 1
    It would be even better to include the essential parts of the walkthrough here (in your own words, and incorporating your own screenshots, as applicable), and provide the link for reference. – Eliah Kagan Aug 24 '12 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.