0

I've used the following commands to try and increase my speeds, using testmy.net to check speeds:

gksudo gedit /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

wifi.powersave = 2

echo "options iwlwifi 11n_disable=8" | sudo tee /etc/modprobe.d/iwlwifi11n.conf

Even after implementing and rebooting after each command, I'm still capped at 40Mbps to 58Mbps down on 2.4Ghz in Ubuntu 16.04.3 and Linux Mint 18.2. On Windows 10, I get 80Mbps down easily with 2.4Ghz, and usually get 100Mbps and higher. All three of my laptop's (Thinkpad W520) antennae are connected to this card.

I also tried options iwlwifi 11n_disable=0 and got worse speeds, only 26Mbps down. I believe this command is used to enable 802.11n but lshw -c network doesn't reflect that.

Unfortunately 5Ghz is out of the question because I'm nowhere in range for it to work well. My router is located far away from me.

Also, my link speed fluctuates wildly in Ubuntu and Linux Mint, going from 240-270Mbps down to 120 Mbps in a single minute. What gives?

I usually get 300Mbps in Windows 10.

iwconfig:

wlp3s0    IEEE 802.11  ESSID:"redacted"  
          Mode:Managed  Frequency:2.427 GHz  Access Point: redacted
          Bit Rate=135 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=64/70  Signal level=-46 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:11  Invalid misc:167   Missed beacon:0

lo        no wireless extensions.

enp0s25   no wireless extensions.

Wireless information:

03:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 35)
Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN
Flags: bus master, fast devsel, latency 0, IRQ 40
Memory at f2900000 (64-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

0d:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 08) (prog-if 01)
Subsystem: Lenovo MMC/SD Host Controller
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at f2100000 (32-bit, non-prefetchable) [size=256]

lshw -C network:

*-network
   description: Wireless interface
   product: Centrino Ultimate-N 6300
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0
   version: 35
   serial: 00:24:d7:d0:6a:d8
   width: 64 bits
   clock: 33MHz
   capabilities: bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=4.10.0-35-generic firmware=9.221.4.1 build 25532 ip=redacted latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:40 memory:f2900000-f2901fff

Output of sudo apt install inxi -y && inxi -F && dmesg | grep -i error in Linux Mint:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
inxi is already the newest version (2.2.35-0ubuntu1).
The following packages were automatically installed and are no longer required:
  lib32gcc1 libc6-i386 xserver-xorg-legacy
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
System:    Host: [redacted] Kernel: 4.10.0-35-generic x86_64 (64 bit)
           Desktop: Cinnamon 3.4.6  Distro: Linux Mint 18.2 Sonya
Machine:   System: LENOVO (portable) product: 4270CTO v: ThinkPad W520
           Mobo: LENOVO model: 4270CTO
           Bios: LENOVO v: 8BET63WW (1.43 ) date: 10/20/2016
CPU:       Quad core Intel Core i7-2760QM (-HT-MCP-) cache: 6144 KB 
           clock speeds: max: 2400 MHz 1: 2400 MHz 2: 2399 MHz 3: 2400 MHz
           4: 2399 MHz 5: 2399 MHz 6: 2399 MHz 7: 2399 MHz 8: 2400 MHz
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Card-2: NVIDIA GF108GLM [Quadro 1000M]
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1600x900@60.00hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 17.0.7
Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.0-35-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: enp0s25 state: down mac: f0:de:f1:bf:03:2c
           Card-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi
           IF: wlp3s0 state: up mac: 00:24:d7:d0:6a:d8
Drives:    HDD Total Size: 756.2GB (5.1% used)
           ID-1: /dev/sda model: HITACHI_HTS72755 size: 500.1GB
           ID-2: /dev/sdb model: LITEONIT_LMT size: 256.1GB
Partition: ID-1: / size: 204G used: 6.4G (4%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 33.55GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 47.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 3016
Info:      Processes: 255 Uptime: 3 min Memory: 1084.2/31950.1MB
           Client: Shell (bash) inxi: 2.2.35 
[    4.598520] EXT4-fs (sdb1): re-mounted. Opts: errors=remount-ro
[    4.760207] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
[    4.760374] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2

Is this a driver issue or am I missing something important? Where's 802.11n, and why doesn't it show up in lshw -c network's output? How do I enable abgn for this card? Thanks.

EDIT: All right, so I went downstairs to the basement with my laptop (on Linux Mint) and tested my 5Ghz speeds next to my router in Linux Mint. My 5Ghz signal is too weak to penetrate upstairs to my bedroom, which is where I am, so I'm forced to use 2.4Ghz upstairs.

I get 90-104Mbps down and 11 up with 5Ghz (full signal strength, right next to my router) in Linux Mint. The same 2.4Ghz speeds I get in Windows 10. Strange.

But when I test 2.4Ghz in Ubuntu and Linux Mint, I only get 56Mbps average, but sometimes it goes down as low as 27Mbps. The link speeds changes rapidly in both distros, going from 270 Mb/s all the way down to 1Mb/s at times. I'm using the latest wireless driver from Intel for the 6300 AGN.

What gives? Is 802.11n broken in Linux? Does the issue lie with Intel's Linux driver? Some kind of conflict between iwlwifi and iwldvm?

I guess the only practical solution to this problem is to ditch the n band entirely and switch to 5Ghz, as long as you're lucky enough to get a full signal with your network card (unfortunately I do not fall into this category as of yet due to personal restrictions). Or just get an 802.11ac card and save yourself the pain. 👎

  • Please add the output of iwconfig to your question. Are you sure you are connecting to an n instead of a g network? – ubfan1 Oct 8 '17 at 0:25
  • I will do that, thanks. And I don't know how to connect to 802.11n. I tried enabling it using options iwlwifi 11n_disable=0 but it didn't work. The card still shows up as 802.11, but with worse speeds. – UnityLauncherProblems Oct 8 '17 at 0:29
  • I have a w520 with an older 6205 card, no special config needed to connect to an n network. Select the n network, and connect. Your router may offer separate g and n networks, if you use different ESSIDs, you should be able to connect to either. I see 135Mb/s on your iwconfig output, so you are probably on an n. – ubfan1 Oct 8 '17 at 1:17
  • I only have n enabled on my router for 2.4Ghz so it has to be connecting to n only even though it doesn't mention it anywhere in those outputs. The link speed gets about as high as 270Mbps in Linux sometimes, but never 300Mbps, and I'm never able to exceed 58Mbps down. I don't know if that's due to driver limitation or something else. I'm able to get 100Mbps down in Windows and a 300Mbps link speed. – UnityLauncherProblems Oct 8 '17 at 2:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.