0

Hello fellow Ubuntu users! Im very new to Ubuntu and im not too IT savy. I tried to install Ubuntu 16.04.3 LTS on my my Windows 7 Alienware m17xr4 off of a LIVE USB.

Im trying to do a dual boot. I partitioned my HDD by going into diskmgmt.msc and using the windows partitioning tool. I booted Ubuntu (try Ubuntu) then proceeded to the installer and chose the option Install along other operating systems, which is kind of weird because I have no other operating systems on my system (maybe its the 38gbs of partitioned space for the factory Alienware Recovery). Anyhow, I get up to the part where its installing GRUB and then it gives me the error

executing 'grub-install/dev/sda'failed
This is a fatal error

I've seen the manual partitioning steps but my partition table looks nothing like what I see in the pictures. Mine shows up as RAID and has weird names that I cant make sense of for which one i need to partition to...

Please help me out here =)

1 Answer 1

1

Please notice that installing an operating system is risky, so backup everything, that you cannot afford to lose before you start (or continue).


You should use Windows to shrink the Windows partition and create unallocated drive space. After that you should reboot Windows and let it adjust to the new size of its partition.

Then you should boot from the Ubuntu boot drive and let the Ubuntu installer use the unallocated drive space for Ubuntu (or if you know what to do, to use gparted and create partitions for Ubuntu, and then start the Ubuntu installer).


If you let Windows create partitions, it might (will probably) create dynamic partitions, which cannot be used by linux (and Ubuntu is a linux distro). If this is the case, you can remove this new partition (these new partitions), but be careful! Do not destroy what belongs to Windows.

4
  • paste.ubuntu.com/25693411 is my bootlog info
    – Dragos75
    Oct 7, 2017 at 15:57
  • @Dragos75, I think there is useful information in the boot-info log :-) /dev/sda3 ends after the last sector of /dev/sda indicates a damaged partition table, that might create problems. Maybe your observations in the original question about RAID is connected to this issue. I have no experience of RAID, so I cannot help you, if there is RAID. On the other hand, if there is not RAID, can you tell me about the second drive, /dev/sdb?
    – sudodus
    Oct 7, 2017 at 16:14
  • Well what i unded up doing was formating all drives and have only Ubuntu installed. O thought that would fix the problem but i still get the damm error...
    – Dragos75
    Oct 9, 2017 at 6:33
  • Did you manage to turn off everything related to RAID? Maybe there is a setting in the BIOS/UEFI menus about it?
    – sudodus
    Oct 9, 2017 at 6:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .