5

I have a series of .jpg files that do not show on Ubuntu Image Viewer or as thumbnails. These are perfectly ok on Windows 32 and 64 and on Mac OS.

Strangely one very old .jpg file does display correctly and its thumbnail is visible in Files no bother just these new ones.

After one hair pulling exercise found some which would not display on Windows were wrongly tagged as .jpeg by extension removed all these. Now all are on a memory stick which works ok on Windows and Mac just not on Ubuntu.

Can anyone help? Please bear in mind this is only my third day with Linux installed for the first time.


Update: outcomes of some suggested fixes

  1. Suggestion:
    Right click on a jpg files, select "open with another application" and try other suggested applications. Also try to open with a web browser like Firefox or Chrome.
    Outcome:
    Just tried opening with Firefox opens ok. Also tried imagemagik and shotwell all display the images no bother.
  2. Suggestion:
    Copy one of the failing jpg files to another folder. Then right click on it and select rename and remove the .jpg part (i.e. change imagename.jpg to imagename). Then double click on it.
    Outcome:
    Just tried the last one and removed the extension i.e .jpg the thumbnail appeared immediately. Also works on simple double click.
  • The first thing was that I looked at the files using "Files" no thumbnails. read a few posts and found the preferences and changed to show thumbnails no change. I then double clicked on an image and no image appeared it seemed it was image viewer that was used to make the attempt at viewing the image. – collectordave Oct 7 '17 at 16:19
  • After scratching the head I noticed an older .jpg image that displayed correctly including it's thumbnail leads me to think something is wrong with my jpegs so downloaded again directly from the internet and no change. – collectordave Oct 7 '17 at 16:20
3

As per the traits you have mentioned it seems that the jpeg files in question are wrongly suffixed (it should have been something else, not .jpg). Although in a GNU/Linux based OS file extensions don't matter per se, some applications like Image Viewer may fail to show the image properly because of the wrong suffix.

You may try one of the workarounds.

Use another application

Right click on one of the problematic jpeg files, select Open With Other Application and try other suggested applications to see which one works. As you have already mentioned ImageMagick and Shotwell are working fine, you may use one of them to open jpeg files by default.

To do that right click on a jpeg file and select Properties. Then go to the Open With tab, select say Shotwell from the list and click on the Set as default button.

Remove suffixes

A cumbersome workaround would be to just remove the .jpg suffix from those files.

To do that right click on a file and select Rename and remove the .jpg part (i.e. change imagename.jpg to imagename). Now the file should open fine with Image Viewer and File Manager should also show the thumbnail.

Warning: An image without an extension might fail to open in another OS (for example Windows).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.