I am new to Linux and I have Ubuntu 17.04 64-bit (Budgie).

I cannot open steam. It is updated to latest version. When I open it it pops up but after some time it disappears. When I try to run it from a terminal I get this output:

tar: This does not look like a tar archive
xz: (stdin): File format not recognized
tar: Child returned status 1
tar: Error is not recoverable: exiting now
find: ‘/home/ghazi/.steam/ubuntu12_32/steam-runtime’: No such file or directory
  • 1
    it's very strange that you get this output! What command are you using in the terminal exactly?
    – Zanna
    Oct 7, 2017 at 8:07
  • i just simply write steam because writing the name of app in terminal opens it Oct 7, 2017 at 10:38
  • that was the right thing to do, however I am surprised that steam is calling tar to do something. Hopefully someone can explain it
    – Zanna
    Oct 7, 2017 at 10:52
  • 1
    @Zanna not that surprising. The Steam client downloads runtime updates directly from Steam servers. Presumably this tar archive is an update that got corrupted or partially downloaded.
    – muru
    Oct 7, 2017 at 11:50
  • so what do i need to do? Oct 7, 2017 at 12:08

1 Answer 1

  1. Run the following command in terminal:

    mkdir "/home/$USER/.steam/ubuntu12_32/steam-runtime"
  2. Then launch Steam.

  • Worked for me. This answer should be accepted! Sep 14, 2018 at 12:14
  • Still works on 18.10, I incurred in the issue after removing the flatpak version, maybe someone else can manage to connect the dots
    – dsSTORM
    Jan 6, 2019 at 14:20
  • 1
    Worked on Ubuntu 18.04
    – Ced
    May 3, 2019 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.