19

I use Kubuntu 17.04 with Auto Login. My Login password is different than my Keyring and Kwallet passwords. Each time I open Skype for Linux Beta 5.5.0.1 a dialog box opens saying

Enter password for keyring "default keyring" to unlock.

I enter the password and I can use Skype. I would like not to have to enter my password each time. I did some searching in Dolphin and found I have Ubuntu, Gnome and Python keyrings. I can find nothing in my applications or settings to access the keyring. I do have KDEwallet/Kwalletmanager. What can I do?

Some think this is caused by the presence of dbus-user-session

$ dbus-user-session --version
dbus-user-session: command not found

With Auto Login to Kubuntu enabled:

$ ps aux | grep keyring
user  1808  0.0  0.0  14288  1024 pts/1    S+   19:06   0:00 grep --color=auto keyring

With Auto Login disabled:

$ ps aux | grep keyring
user  1258  0.0  0.1 203168  5152 ?        Sl   20:35   0:00 /usr/bin/gnome-keyring-daemon --daemonize --login
user  1856  0.0  0.0  14288   972 pts/1    S+   20:36   0:00 grep --color=auto keyring
17
  • 1
    Do you use auto login? If yes, stop auto login and mostly you won't be troubled by keyring.
    – abhishek
    Oct 7 '17 at 7:48
  • 3
    The keyring is unlocked/decoded with your password. Any login without a password, like autologin or a fingerprint reader will therefor not open the keyring, so you have to manually enter the pw when an application requests the keyring.
    – ubfan1
    Oct 7 '17 at 15:21
  • 2
    From help.ubuntu.com/stable/ubuntu-help/user-changepassword.html : To change the keyring password (to match your login password): Open the Passwords and Keys application from the Dash. In the View menu, ensure By keyring is checked. In the sidebar under Passwords, right-click on Login keyring and select Change Password.
    – ubfan1
    Oct 8 '17 at 16:03
  • 1
    I changed my login password to be the same as my keyring password (and my kdewallet password) and disabled auto login. I no longer need to enter my keyring password to open Skype (nor my kdewallet password to open other programs). For this system to take effect I needed to "quit Skype" (and not just close the window), shut down and boot again. It seems to have a side effect that my Samba share on the network didn't work until I changed my network password to be the same as my keyring password. @ubfan1, Kubuntu doesn't seem to have Dash, just KDEwallet, w/o access to keyrings. Oct 9 '17 at 3:45
  • 2
    You should edit your question and clarify why it isn't a dupe, especially “Each time I open Skype” makes it sound like a different problem I think. I'll cast a reopen vote and if others do the same the question will be reopened for you to answer. Thank you for the effort!
    – dessert
    Oct 9 '17 at 6:22
8

I've solved this problem as follows:

  1. In the Kubuntu launch menu, type password to find the utility Passwords and Keys. Open this utility.
  2. In the panel on the left you should see an entry Login in the section Passwords. Right click on Login, and select Change Password from the pop-up menu.
  3. You'll need to enter your current password first, then it asks for a new password
  4. Just leave the fields blank and press Continue.

Once you have done that, you should be able to open Skype without being prompted for the keyring password.

Obviously, this approach assumes you are fine with not having this extra layer of security on your keyring, but I expect for most home users this is perfectly fine.

For more info, look at http://ask.xmodulo.com/disable-entering-password-unlock-default-keyring.html

4
  • 11
    Just to add that the referred utility, in case you don't have it installed, is accessed by apt-get install seahorse
    – DrBeco
    Jan 4 '18 at 20:33
  • This did not work for me (Kubuntu 16.04), i.e., setting an empty password, until I also (a) selected Unlock; and (b) Select as default for the Login keyring.
    – kavadias
    May 24 '18 at 16:45
  • I'm getting a warning about storing my password unencrypted, don't think it's the right way to go
    – szx
    Nov 7 '19 at 17:48
  • @DrBeco I couldn't find this "Password and Keys" and I was going mad... but I installed seahorse and now I have "Password and Keys". Also the layout has changed, so you have to open it and then go back with the arrow in the top left, the right click on default keyring and then change password :)
    – Allexj
    Dec 30 '20 at 22:26
1

I changed my login password to be the same as my keyring password (and my kdewallet password) and disabled auto login. I no longer need to enter my keyring password to open Skype (nor my kdewallet password to open other programs). For this system to take effect I needed to "quit Skype" (and not just close the window), shut down and boot again (The default option for Kubuntu to restart or shut down is to save the session. This can sometimes keep the applications of some settings. I changed my default to start with a new session). It seems to have a side effect that my Samba share on the network didn't work until I changed my network password to be the same as my keyring password.

3
  • This answer is actually not working now. I'll have to dig some more. Nov 1 '17 at 10:37
  • 1
    can you please let us know if you find the solution?
    – Dmitriy
    Nov 15 '17 at 13:23
  • disabled autologin - at least that should have fixed it.
    – user47206
    Jul 9 '18 at 7:56
1

When install or create an account, just press Cancel if skype requires a key ring. Next time if you log in, just click Cancel.

1

The situation in 18.04 - with solution:

  • the tool that triggers this is gnome-keyring, which came with the installation (from deb) of skypeforlinux; removing gnome-keyring is not normally possible (that is, with apt and such), as it would also remove Skype. (It can forcibly be removed, but that would lead to skypeforlinux being reported as broken, while sudo apt install -f will simply install gnome-keyring back.)

  • autologin disabled (in my case)

  • seahorse not installed

  • KDE Wallet disabled

  • when asked to enter the keyring password, click "Continue" until the prompt closes

  • at this point Skype starts but it may get stuck; it may even need to be killed from System Activity; after that, when started again it will log in normally, no keyring prompt anymore

1
  • Yes. It works now. I had to reinstall skype though. First I removed skype and gnome-keyring . Then I deleted the .local/share/keyrings/ folder. Finally installed skype via Snap. I loaded skype and did cancel on all prompts, but it did not work. Then I restarted skype and followed your advice. Thank you.
    – makkasi
    Jul 3 '20 at 16:20
0

It is sufficient to install a key ring manager as SeaHorse: you will be prompted to the keyring password and next time Skype will autologin. Probably the first time you have to logout from Skype and relogin.

0

I've installed skypeforlinux on Gentoo, so having these Gnome prompts showing up was a bit of surprise. For those coming from other distros getting here through search this is what I've figured. As a dependency skypeforlinux pulls in libsecret which pulls in gnome-keyring.

tl;dr If I understand it correctly after you login to skypeforlinux it stores access token to Microsoft servers into this keyring "thing", so next time you start skypeforlinux it just asks the keyring for the token so you don't need to relogin to skype. That is as long as the gnome-keyring-daemon is running and you did unlock the "Default keyring" in it using password when prompted at least once. What password it is? Well the one you created the Default keyring with. To me it was my Skype password (as Skype was the only app ever asking for it).

The actual keyring file we're talking about is stored in ~/.local/share/keyrings/Default_keyring.keyring and can be accessed using e.g. utility called seahorse.

The "thing" is not an anonymous password prompt anymore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.