3

UPDATE: None of the provided answer to this date (2017.10.16) have helped me solve the problem, so in a fair world no one should get the bounty. I should emphasis that the provided answer were either not in the direction of answering the question (like those who suggested installing Gnome) or their suggestion didn't work on the computer that I have this issue on. Nevertheless i appreciate the time and effort they have put into this.

This might look like a duplicate post but IT'S NOT since none of the suggestions and solutions in other posts worked in my case.

Problem description: Everything was going fine but I faces some sort of lags, so I rebooted the computer and after logging in to my account, Unity didn't load properly. I rebooted multiple times and ... Nothing.

What I did: I tried all the solutions and suggestion out there an none of the solutions out there worked. Things like:

the top 10 suggestions here: Unity doesn't load, no Launcher, no Dash appears

or

unity-tweak-tool --reset-unity

or

unity --reset-icons

or

unity --reset

or

gconftool --shutdown
sudo killall -r -I gconf
sudo killall -r -I dconf
rm -rf .compiz* .gconf* .config/dconf/ .config/compiz*

My Idea and question: Based on a suggestion of my friend, I tried to login with another user and it worked! everything was fine, which narrowed down that some settings in my account is corrupted!

The question is, Which files should I transfer from the other account that Unity works fine on to my own account?

When I try to run Unity from terminal I get the following:

$unity
unity-panel-service stop/waiting
unity7 stop/waiting
unity-panel-service start/running, process 6549
unity7 start/running, process 6648
  • 1
    Which files should you transfer? no idea, but try resetting dconf. First backup with dconf dump / > dconf.bak. Then reset with dconf reset -f / if it didn't worked, you can restore it with dconf load / < dconf.bak. You can also create a temporary admin acc, backup your account, delete it, recreate your account and retrieve from the backup only the things you need (some programs conf files and personal stuff). – eridani Oct 13 '17 at 21:28
  • I bow to your wisdom: answer deleted... – Fabby Oct 17 '17 at 21:45
  • I just had the same problem and the only solution that did it for me was this: <p> itsfoss.com/… <p> To answer you question "Which files..." it seems core.pb is the one. – leo277 Mar 7 '18 at 18:05
2

Assuming you can access the terminal, have you considered downloading and switching to another desktop environment? Recently I had a very similar problem with compiz/unity and the only solution was switching to GNOME 3. If you don't really care that much about the GUI, maybe that's the way to go.

So you can access your account and you can log into other accounts without any problem. I'm just guessing but maybe it's worth a try.

sudo apt-get install ubuntu-gnome-desktop

By the way, It can be a great moment to getting to know GNOME because the next LTS Ubuntu release will have it as default, from what I've heard.

  • I already did that, but that does not return my precious unity and is not an answer to my question which is which files I should copy from a healthy account. (since you mention it, I used moved from Fedora to Ubuntu because of Gnome3 back in the day. from the next LTS I will move to something else unless they get rid of all the terrible awful ugliness and roughness of Gnome3, probably KDE or Pantheon or worst case to MATE) – Mehrad Mahmoudian Oct 13 '17 at 11:57
  • 1
    I know it was not an answer to your question, I was just making sure you had considered other options. I don't know what " terrible awful ugliness and roughness of Gnome3" you are talking about, though. – pvaesrtdoe Oct 13 '17 at 14:55
  • 1
    Thank you @pvaesrtdoe, I was in crunchtime today and Ubuntu Unity, for no reasonable explanation borked completely as described by the OP. I tried many of the suggestions and none worked so I took your suggestion. I was fine with Unity, but in this case necessity is the motivator for me learning a new desktop environment. It's been very easy so far. – Shai Mar 8 '18 at 22:59
2

Probably a disabled installation here at your desktop. You could try to solve this with:

sudo apt-get update

then

sudo apt-get install --reinstall lightdm ubuntu-desktop

It can happen that there appears a query, which display-manager you want to set as main display-manager ---> so simply choose then lightdm.

Hope this helps. Here you can find more explanations about lightdm:

https://wiki.ubuntu.com/LightDM

And here more explanations about unity:

https://wiki.ubuntu.com/unity

  • After many attempts, this answer solved the issue for my laptop: it was probably the lightdm package, since I had tried to reinstall ubuntu-desktop before to no avail. Thanks a lot! – Erwan Mar 12 '18 at 14:30
0

This just happens on my 16.04. These steps worked for me (credit to It's FOSS):

  1. Press Ctrl+Alt+F1 to access the console.
  2. Use your normal username and password to login.
  3. Type sudo apt update
  4. Type sudo apt install --reinstall ubuntu-desktop
  5. Type sudo shutdown -r now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.