-3

I have been trying to access a folder to install a program and I keep receiving the following error message:

bash: cd: *: No such file or directory

I then tried accessing the desktop with the command cd desktop and received the following message:

bash: cd: desktop: No such file or directory

I've tried re-installing Terminal to see if that fixes the problem but still get the same messages.

Can anyone help with this issue? Accessing files and folders works normally through the Unity user interface.

EDIT: Solution found in comments and is not part of existing command-line questions.

8

1 Answer 1

8

Obviously, you're not paying attention to the cases when dealing with folder names in Linux. Linux is case sensitive, so you must enter the names with letters in the correct case.

You probably have these default directories in your home directory (it will vary depending on your locale:

Documents, Desktop, Downloads, Music, Pictures, Videos

These start with a capital letter and can only be entered using cd followed by the exact, case sensitive name, or an appropriate wildcard. You are free to name other custom folders (created by you) as you desire, but note you will need to remember their letter case to be able to access them.

Example: George and george are two different folders and may be found in the same parent directory, so always pay attention to the letter case when dealing with folders and files on Linux.

Another important thing to note is the fact that your home directory is structured thus:

/home/<your_username>/...

and that /home/<your_username> is the same as the ~ character so these are the same:

cd ~/ <==> cd /home/<your_username>/
cd ~  <==> cd /home/<your_username>

Doing cd ~ will take you to your home folder, and Linux has another shortcut cd that when used will take you there also. Feel free to read up, and have fun. Welcome to the Linux World.

1
  • Hi George, thank you for your in depth answer. I didn't even notice the lowercase "d" when I typed out my command. Panther already spotted this issue in the comment string. Not too sure why it was flagged as a duplicate post, as no one seems to have had this issue (no focus on case sensitivity). Thanks again though for additional information!
    – Berrik
    Oct 26, 2017 at 1:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.