1

I got into some mess on my install, so I thought I'd reinstall pulseaudio. After that, I had a problem with pulseaudio not spawning at boot; somehow after some changes and reboots, now pulseaudio is spawning again at boot (and also after pulseaudio --kill).

I think I eventually did the equivalent of:

sudo apt-get remove --purge pulseaudio
sudo apt-get --reinstall install mate-applets mate-applets-common \
  mate-desktop mate-desktop-common mate-desktop-environment-core \
  mate-applets mate-applets-common mate-indicator-applet mate-gnome-main-menu-applet \
  mate-media mate-media-common mate-media-pulse mate-menu mate-notification-daemon mate-panel \
  mate-panel-common mate-settings-daemon mate-settings-daemon-pulse \
  pulseaudio pulseaudio-module-gconf pulseaudio-module-x11
rm -rf ~/.config/pulse
rm -rf ~/.pulse

After reboot and re-run of pulseaudio, ~/.config/pulse gets reconstructed, ~/.pulse does not. These are messages from syslog from that reboot:

$ grep pulse /var/log/syslog
Oct  5 12:06:33 mypc pulseaudio[1634]: [pulseaudio] authkey.c: Failed to open cookie file '/etc/timidity/.config/pulse/cookie': No such file or directory
Oct  5 12:06:33 mypc pulseaudio[1634]: [pulseaudio] authkey.c: Failed to load authorization key '/etc/timidity/.config/pulse/cookie': No such file or directory
Oct  5 12:06:33 mypc pulseaudio[1634]: [pulseaudio] authkey.c: Failed to open cookie file '/etc/timidity/.pulse-cookie': No such file or directory
Oct  5 12:06:33 mypc pulseaudio[1634]: [pulseaudio] authkey.c: Failed to load authorization key '/etc/timidity/.pulse-cookie': No such file or directory
Oct  5 12:06:33 mypc pulseaudio[1634]: [pulseaudio] authkey.c: Failed to open cookie file '/etc/timidity/.config/pulse/cookie': No such file or directory
Oct  5 12:06:33 mypc pulseaudio[1634]: [pulseaudio] authkey.c: Failed to load authorization key '/etc/timidity/.config/pulse/cookie': No such file or directory
Oct  5 12:06:33 mypc pulseaudio[1634]: [autospawn] core-util.c: Home directory not accessible: Permission denied
Oct  5 12:06:33 mypc pulseaudio[1634]: [autospawn] lock-autospawn.c: Cannot access autospawn lock.
Oct  5 12:06:33 mypc pulseaudio[1634]: [pulseaudio] main.c: Failed to acquire autospawn lock
Oct  5 12:06:51 mypc pulseaudio[2441]: [pulseaudio] pid.c: Daemon already running.

And indeed pulseaudio runs now:

$ ps axf | grep -v grep | grep pulse
 2173 ?        S<l    0:00 /usr/bin/pulseaudio --start --log-target=syslog
 2302 ?        S      0:00  \_ /usr/lib/pulseaudio/pulse/gconf-helper

However, my top bar looks like this:

/media/Data1/sopost-top-1.png

... that is, there is no volume control/volume applet - it is missing. Otherwise, here is where the word volume occurs in mate packages:

$ dpkg-query -S mate-volume
mate-media-pulse: /usr/share/man/man1/mate-volume-control.1.gz
mate-media-pulse: /usr/share/man/man1/mate-volume-control-applet.1.gz
mate-tweak: /usr/share/mate-tweak/mate-volume-control-applet.desktop
mate-tweak: /usr/lib/mate-tweak/disable-mate-volume-applet
mate-media-pulse: /usr/bin/mate-volume-control
mate-media-pulse: /usr/share/applications/mate-volume-control.desktop
mate-media-pulse: /usr/bin/mate-volume-control-applet

When I run mate-volume-control I get the "Sound Preferences" window:

/media/Data1/sopost-sp1.png

When I run mate-volume-control-applet, I get:

/media/Data1/sopost-top-2.png

... a volume icon in top bar, but when I click on it, it just shows a slider.

However, by default, this volume applet is shown in Ubuntu Mate 14.04:

/media/Data1/sopost-top-3.png

... with player buttons and such; and looking at ps axf | grep 'mate\|applet\|volume\|pulse', there is nothing that specifically indicates a process which would be generating it, so I guess this volume applet is part of mate-indicator-applet-complete. I also did:

mate-panel --reset --replace

... (had to do it twice before the bars reappeared), which didn't restore the volume applet either.

In any case - how can I restore now this "proper" volume applet at startup, not the "just-a-slider" one by mate-volume-control-applet? Or, in other words, what is the proper re-installation procedure, to reinstall pulseaudio and corresponding MATE desktop applets?

1

Ok, I think I managed - the short answer is: indicator-sound-gtk2;

First, I also tried running:

mate-tweak

... then choose Interface / Panels / Select a panel layout to change the user interface:

tweak

... when you change the choices from "Ubuntu MATE" to "Ubuntu MATE with MATE Menu" and back to "Ubuntu MATE", then the volume icon in bar is restored, but it shows just the slider, not the default applet.

Then (by doing a reverse image search) I realized that the menu I was seeing is actually the default one shown in Gnome desktop on 14.04; after grepping through the ps axf, I realized what is shown is indicator-sound. Well, since MATE is gtk2 (and I think Gnome is gtk3 on Ubuntu 14.04), it turns out there actually is a package, indicator-sound-gtk2. So I installed it:

sudo apt-get install indicator-sound-gtk2

... but after reboot still got the old indicator. Then I found Bug #1337241 “Sound Settings menu item in indicator-sound-gtk2 d...” : Bugs : indicator-sound-gtk2 package : Ubuntu, according to which I tried:

sudo apt-get --reinstall install mate-indicator-applet indicator-sound-gtk2 mate-settings-daemon-pulse mate-media-pulse

... but after reboot still got the old indicator. Then I did:

  1. Remove Volume Control (mate-volume-control-applet) from the autostart apps.

... and rebooted; cannot recall if the volume icon was still shown on top bar or not, but mate-volume-control-applet was not in process list. So I tried to run indicator-sound-service:

$ /usr/lib/indicator-sound-gtk2/indicator-sound-service

(process:4697): libindicator-WARNING **: No watchers, service timing out.

... but it failed. Then I found [xubuntu] indicator-sound reporting "no watchers":

Make sure indicator-sound-gtk2 is installed and that you have the Indicator plugin in one of your panels. This one (usually) also shows network connectivity and mail messages.

So I removed all the indicators from the top bar (kinda tricky, you have to right click on indicator, not panel [and not on actual indicator], empty space, to get the right-click menu option to unlock and/or remove the indicator. Then re-add the "Indicator Applet" or "Indicator Applet Complete" to top bar, try again:

$ /usr/lib/indicator-sound-gtk2/indicator-sound-service

(process:4872): libindicator-WARNING **: Name request failed.

... the command exits immediately, but the service is running:

$ ps axf | grep -v grep | grep sound
 4897 ?        Sl     0:00 /usr/lib/indicator-sound-gtk2/indicator-sound-service

... and finally, now when I click on icon on top bar, I get the apparently Gnome3 indicator sound shown, with player buttons and all. Not sure yet if this will persist a reboot, though? ... yup, apparently it does, can now see volume icon with Gnome 3 indicator-sound in MATE right after boot and login.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.