1

Been dealing with this issue at work, can't connect to the Wifi network here.

It works on another of my laptop with the same OS and a different network card, but this Thinkpad T401s with a rtl8191sevb card can't stay connected.

The wifi will connect, ping or any other network service won't work, and after a few seconds it disconnects me. Then it just loops over that endlessly.

Following is the syslog when this happens.

We can see that I'm getting a DHCP lease, but then we start seeing something like "Michael MIC failure detected", and "TKIP countermeasures started" just before "deauthenticating from 02:18:4a:bb:32:f0 by local choice (Reason: 14=MIC_FAILURE)"

The network here is using WPA2 with TKIP (not AES)

Things I tried so far:

Uninstall TLP, disable power saving in the BIOS, disabled wifi card power saving.

sudo iwconfig wlan0 power off

sudo killall wpa_supplicant

Adding "options iwlwifi 11n_disable=1" to iwlwifi.conf

Unfortunately this is not my AP so I have to live with TKIP. Any ideas?

Here is the paste from wireless-info: https://pastebin.com/M4VtvDqM

Here are the system logs when this issue is occurring: https://pastebin.com/zL9NrY0q

Quite frustrating that this works on 3 out of my 4 machines. Just this one thinkpad 410s is giving me troubles!

Thanks!

  • Sep 27 16:06:45 t410s wpa_supplicant[1162]: wlp3s0: Michael MIC failure detected and kernel: [ 232.254544] wlp3s0: deauthenticating from 02:18:4a:bb:32:f0 by local choice (Reason: 14=MIC_FAILURE) and Sep 27 16:06:49 t410s NetworkManager[972]: <warn> [1506553609.5351] sup-iface[0x1c5d7a0,wlp3s0]: connection disconnected (reason -14) deserve investigation. perror 14 says OS error code 14: Bad address. – waltinator Oct 5 '17 at 7:06
  • Thanks for the response. I've done quite a bit of research before posting here, hence why there's quite a lot of things under "things I tried so far". For example I tried everything on this page: askubuntu.com/questions/343446/… – Megalex Oct 5 '17 at 16:52
  • Anyone has any ideas? – Megalex Oct 6 '17 at 15:23
  • Anyone wanna take a stab at this? Would love for this computer to work right! – Megalex Oct 10 '17 at 21:04
1

I was able to permanently fix the problem by installing windows 10. Now the wireless works perfectly!!

One day Linux will be ready for the desktop! Slowly getting there

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.