3

On my new ASUS laptop I have an Elantech touchpad which works great out of the box (I'm running 17.10 beta). The only problem I have is with sensitivity, which feels not sufficient. For example often the first time I tap on the touchpad, the click is not registered and a second or third tap is required.

Running libinput on a Wayland session, I looked through the relative documentation and found this: https://wayland.freedesktop.org/libinput/doc/latest/touchpad_pressure.html#touchpad_pressure_hwdb The problem is that measure-touchpad-pressure doesn't seem to be included in the libinput-tools package (https://packages.ubuntu.com/artful/amd64/libinput-tools/filelist)

So, is there a way in which I can tweak my touchpad's sensitivity?

closed as off-topic by Pilot6, karel, Fabby, storm, Eric Carvalho Oct 10 '17 at 19:45

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Pilot6, karel, Fabby, storm, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Isn't there a slider under Mouse$Touchpad? – mikewhatever Oct 4 '17 at 17:17
  • That controls cursor speed – saintjules Oct 4 '17 at 17:42
  • Could this possibly be related to focus-stealing? It seems like focus stealing prevention might cause this so you would have to click two times to register the new focus. – mchid Feb 13 '18 at 3:46
  • Either that or it sounds like you might have palm detection on or possibly something to do with the noise cancellation set too high? – mchid Feb 13 '18 at 3:49
  • You can run xinput list to determine the touchpad device number (like, device number 12 for example). Then, for example, you could run xinput list-props 12 to list all of the device parameters available. Each one of these parameters is also listed with a number. For example, Synaptics Palm Detection (304). So, to set Synaptics Palm Detection on device number 12 to 0 you could run the following command: xinput set-prop 12 304 0 which would disable palm detection. If you find a setting you like, you can permanently it by including these parameters in your libinput config file. – mchid Feb 13 '18 at 4:01