4

(I turn the whole internet upside down for the past 20 hours, none of the similar threads helped)

This is between two debian(from) and purchase iptv ubuntu(to) servers moving files from one machine to a remote machine.

Yesterday I tried to move over 1.5 TB folder from my old server to a new one. I was advised to use rsync command. I ran the command like this.

sudo rsync -zvh -e ssh —progress /my/old/server/from/ root@123.123.123.123:/my/new/server/to/

First time it was going just fine and after a minute I accidentally stopped the process by ctrl+c . Now whenever I execute the command again, it doesnt work and tells me:

rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1196) [sender=3.1.2]

1

Log the output to a file (using even more -v's to be even more verbose) and then grep for "rsync:". That should show you the exact files rsync is having trouble with.

Example of how to log:

sudo rsync -zvvvvh -e ssh —progress /my/old/server/from/ root@123.123.123.123:/my/new/server/to/ >&! /tmp/logfile.txt

The above works in tcsh. If you're using bash, I think you need 1> /tmp/logout.txt 2> /tmp/logerr.txt to redirect the output, but I'm not 100% sure.

You can also use |& tee /tmp/logfile.txt if you want to watch the output as it's generated. You may want to do this just to see if rsync is being too verbose, and cut down the number of -vs until you're happy with the output.

  • Hi, How do I log the output? where does the log of this rsync get stored? and also what did you mean by "using even more -v's to be even more verbose"? – ALi gg Oct 4 '17 at 15:11
  • Edited to answer your questions (hopefully) – barrycarter Oct 4 '17 at 15:17
0

My destination server had a hard disk issue and I configured it with RAID0, now it is on RAID5 and is working just fine.

0

This is what I have got byt this command:

sudo rsync -zvvvvvvvvh -e ssh —progress /my/old/server/from/ root@123.123.123.123:/my/new/server/to/ 1> /tmp/logout.txt 2> /tmp/logerr.txt


msg checking charset: UTF-8
(Client) Protocol versions: remote=31, negotiated=31
[sender] change_dir(/home/xxxxxxxx/xxxx/movies)
skipping directory .
[sender] flist start=0, used=0, low=0, high=-1
send_file_list done
[sender] flist_eof=1
file [iptv trial][1] list sent
send_files starting
server_recv(2) starting pid=5715
received 0 names
[Receiver] flist_eof=1
[Receiver] flist start=0, used=0, low=0, high=-1
recv_file_list done
get_local_name count=0 /home/newfiles/
[Receiver] change_dir(/home/newfiles)
generator starting pid=5715
delta-transmission enabled
generate_files phase=1
send_files phase=1
recv_files(0) starting
recv_files phase=1
generate_files phase=2
send_files phase=2
send files finished
total: matches=0  hash_hits=0  false_alarms=0 data=0
recv_files phase=2
recv_files finished
generate_files phase=3
generate_files finished
client_run waiting on 9882

sent 16 bytes  received 426 bytes  58.93 bytes/sec
total size is 0  speedup is 0.00
[sender] _exit_ [iptv server][2] cleanup(code=0, file=main.c, line=1196): entered
[sender] _exit_cleanup(code=0, file=main.c, line=1196): about to call exit(23)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.