-2

My computer has three drives in it:

  • 3 TB HDD formatted as EXT4 for Ubuntu 17.04
  • 640 GB HDD formatted as NTFS for Windows 10
  • 60 GB SSD currently formatted as NTFS for fast game reading on Windows

What do I want to do?

  1. I want to install grub on the SSD for fast bootup
  2. Change the auto-order of grub so that when I boot up it boots into Windows automatically instead of Ubuntu
  3. Be able to change boot order from Windows or Ubuntu

Is this possible? I can imagine #3 will be the hardest as Windows doesn't like anything besides Fat32/NTFS, but if it is, do let me know.

  • 2
    Installing grub to the SSD will not affect boot speeds of either Ubuntu or Windows. To improve boot speeds, you'll need to have both OSs installed on SSDs. – mikewhatever Oct 4 '17 at 11:57
4

1) Grub only gives boot options and launches the appropriate boot loader.
Thus putting it on the SSD will not speed up booting since the actual boot is done from the drive with the OS on it.

2) Edit /etc/default/grub. Change GRUB_DEFAULT=0 to point to the menu entry you want to be default.
For example: GRUB_DEFAULT="Windows 7 (loader) (on /dev/sda2)"

3) Windows can not change the grub boot order.

  • 1
    @MarkKirby that does not change the boot order as saved in Ubuntu. Booting from Ubuntu boots the default as saved in Ubuntu. – Rinzwind Oct 4 '17 at 12:16
2
  1. For faster boot up... assuming that Ubuntu is your primary OS... with your configuration... the best you can do is to install Ubuntu on the SSD, but with the /home directory on the 3TB HDD. Make sure that you've formatted the 3TB drive with a gpt partition table, as it's over 2TB in size. You could also partition the 3TB with an extra NTFS partition so that you could easily share files between Windows and Ubuntu.

  2. See item #3, below.

  3. If you edit /etc/default/grub with the following settings, it'll remember the last OS you booted, and that will become the default OS for future boots.

In terminal...

gksudo gedit /etc/default/grub

add/change these lines near the top of the file...

GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true

save the file and quit gedit. Then...

sudo update-grub
  • Unfortunately the answer no longer applies. My HDD kicked it, and I had to uninstall Ubuntu for now.. – David Oct 8 '17 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.