I have noticed a problem on my dell inspiron 13 series 2-in-1 7359.

The SSD is very slow when it has to copy files. It starts very fast (it does 30%-40% of the job) but after 5-6 second the speed drops at 10MB/s. Which I believe is ridiculous for a SSD.

Also the CPU goes up at 100% when I start copying files.

The problem is not only with Ubuntu 16.04 but also with windows 10.

I have a 256GB SSD (SAMSUNG PM871), and I partitioned it in 3 sections:

  • one EXT4 with Ubuntu 16.04
  • one NTFS with Windows 10
  • one NTFS with no operative system

On Windows I installed a Samsung tester tool and it says my write speed is 300-400MB/s, so everything should be fine but of course it isn't.

I have read several pages that talk about similar problems but I can't figure out a solution.

Some link I visited:

  1. https://bugs.launchpad.net/ubuntu/+source/ntfs-3g/+bug/554764
  2. Ubuntu SSD - Was fast, is now extremely slow
  3. Ubuntu 16.04 slow performance

My CPU is: Intel® Core™ i7-6500U CPU @ 2.50GHz × 4.

  • 1
    Since the problem happens both in Windows and Ubuntu, it is not related to Ubuntu. This is most likely a hardware problem. This is a question answer site about Ubuntu.
    – user68186
    Oct 4, 2017 at 11:06
  • 1
    Can you install a tool to measure heat of SSD? Most will throttle back when they're hot. Oct 4, 2017 at 11:29

1 Answer 1


This is normal behavior for SSDs, especially as they get very full. The reason for this is that SSDs need a lot of time to clear up used blocks. They can only write to free blocks. To be fast, they keep free blocks for future use around. This is one of the reasons the TRIM command is important. After the available free blocks are full, the SSD needs to free up more blocks as it writes which makes writing after it ran out of free blocks a lot slower than before.

  • Thanks for replying! I've understood what the problem is but I don't get how can I solve it. I'm quite sure I have TRIM enabled both on Ubuntu and Windows. How can i tell the OS to keep blocks free for future use? Can you explain it in more detail please?
    – Jacob
    Oct 10, 2017 at 11:01
  • Clearing up space should do the trick. Move some big files to a different storage medium so you got free space. Additionally, you can mount all file systems on your SSD and then issue the command sudo /sbin/fstrim --all. This will trim all the file systems. Note that the command will only trim mounted file systems and only those of which trimming is supported.
    – UTF-8
    Oct 10, 2017 at 11:43
  • Thanks! I'm going to try it! Now this is not related specifically to Ubuntu but why Windows (which is more "user friendly") doesn't do it automatically? Because I have the same problem on Windows 10.
    – Jacob
    Oct 10, 2017 at 11:49
  • By default, Ubuntu issues the command I posted automatically once a week. Windows does something similar. The idea here is that you first clear up some space and then execute the command right away without waiting potentially up to a week between having cleared up space and being able to test whether it improved performance. I noticed that I forgot to ask you something, btw.: Do you use disk encryption?
    – UTF-8
    Oct 10, 2017 at 11:53
  • No I don't use disk encryption, why? I'm looking at my storage and the free space on the EXT4 partition is 20GB free on 50GB total. So I believe I have enough free space right? I have run the command you told me but it still not working properly.
    – Jacob
    Oct 10, 2017 at 12:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .