1

This question already has an answer here:

I recently downloaded Lubuntu 17.04 and created live USB with Unetbootin from windows 10.

Method I used is:

  • Seperate USB partition to : OS(2GiB-FAT32) casper-rw(4GiB-ext4) home-rw(54GiB-ntfs) using Gparted on my Raspberry Pi B+.

  • Set casper-rw file 100MB in Unetbootin and created live USB

  • Edited grub.cfg and added 'persisent' (I'm not sure why persistent is off)

  • Removed casper-rw file

But after booting it, it runs into busybox. No single error message, just 'iniramfs>_'.

I heard there is issue with initrd.lz itself when word 'persistent' is used in grub.cfg but there was no any answer, at least what I searched is. . . . SO, the Question is :Is there any workaround for this? I need this USB to run lubuntu as soon as possible.

And, why syslinux.cfg has word 'persistent' but why grub.cfg don't have it - although both are created by Unetbootin with persistent option?

Please understand that my only Linux accessible is headless Raspberry pi, using VNC&SSH. I already walked enough puting USB stick on Pi and my PC..

EDIT: I fixed this issue via YUMI universal USB installer. No other method worked.

marked as duplicate by David Foerster, Kevin Bowen, Eliah Kagan, Eric Carvalho, Charles Green Oct 17 '17 at 15:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did you check the hashsum of the .iso ? Does it boot without the persistent option? – Panther Oct 4 '17 at 14:16
  • I didn't, but when I used Lili, it do works, but also failes to use persistent when I create casper-rw partition with ext4. Sorry for late reply; – 백준영 Oct 6 '17 at 9:28
0

Put the casper-rw ext4 partition first (make it the first partition on the drive). You need persistent parameter in both menus (syslinux.cfg for MBR booting and grub.cfg for UEFI booting). Unetbootin does not support UEFI-booting so it doesn't bother to change the file.

  • Ofcourse, I added that and it directly ran into busybox. – 백준영 Oct 26 '17 at 8:47
  • As I issued in question, it just shows me 'iniramfs>_' when word 'persistent' is in grub.cfg file. And I guess that's issue of ubuntu itself as shown here: askubuntu.com/questions/664577/… (sorry for long link) – 백준영 Oct 26 '17 at 8:51
  • Is the casper-rw partition the first partition in the partition table on the USB drive and the unetbootin partition the 2nd partition? If so it should work. See rmprepusb.blogspot.co.uk/2017/10/… – SteveSi Oct 27 '17 at 9:18
  • Oh That's what I wanted to know, thanks! I always created Linux one first. But there wasn't option for that - as Unetbootin or Lili just kept formating USB into single partition during operation. Is thee any workaround for it? – 백준영 Oct 30 '17 at 9:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.