1

I have two problems with Ubuntu Center. I'm using Ubuntu 16.04 LTS, which is installed on USB Flash Drive 3.0.

1.After installing Ubuntu

, Software Center looks strange. I used to use Ubuntu few years ago and compared to software center I remember, software center on my new computer looks like old and outdated(Actually, some software was even missing! Maybe I had done something wrong while installing). Software Center on my new computer looks like this: Old, outdated Software Center? I installed new software center, and It looks like this: enter image description here So, do I have old software center? or I'm just confusing old and new one?

2.Newly installed Ubuntu Center won't open

after next boot. Reinstalling solved this, but problem happens again after boot, every time. I tried running software center using console typing 'software-center', and result was this:

2017-10-04 13:52:00,663 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in 
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 338, in __init__
    self.icons)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/appmanager.py", line 66, in __init__
    self.oauth_token = helper.find_oauth_token_sync()
  File "/usr/share/software-center/softwarecenter/backend/ubuntusso.py", line 143, in find_oauth_token_sync
    sso.find_credentials()
  File "/usr/share/software-center/softwarecenter/backend/login_impl/login_sso.py", line 74, in find_credentials
    self.proxy.find_credentials(self.appname, self._get_params())
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

I googled about this, and most answer was about reinstalling, which is not helpful in this case.


Thanks for reading. Have a nice day.

1

Ubuntu has stopped supporting Ubuntu Software Center after the release of Ubuntu 16.04 LTS. So, the default software center on 16.04 and its successors is Gnome Software (at least for now).

Gnome Software has some disadvantages. Although, it may have a better look, it will not show all software available to the official repository, only the ones that are relatively popular. But, it supports some snaps (for example, PyCharm).

And about second problem, there might be some misconfigurations with your internet connection, as the actual problem is:

The maintainer contacted but no resolution and/or answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.