2

i have Dell Precision 3510, and i want to get the most of it. I have on board i7-6820HQ and AMD FirePro W5130m. I'm trying to install some proprietary drives, and this is where i get so far: 1. I installed AMDGPU-PRO, on Ubuntu 16.04 with kernel 4.10 -> stuck after login.

The thing is, that linux see Radeon HD8800M. I have FirePro W5130m, and i don't think it is the same GPU. They have different specs, and i even saw them compared in benchmarks. I think it detects wrong GPU, because here is listed different GPU: https://certification.ubuntu.com/hardware/201508-18812/

I tried Ubuntu 14 and 16. They both have the same problem.

Do you have any idea how to make AMDGPU-PRO working, or make Ubuntu detect the correct GPU? Installing fglrx is not helping, linux still detects wrong gpu, and i can't use fglrx because i don't have supported gpu. Also, i can't download fglrx for Radeon HD880m, because prioperiarty drivers for HD8800m is AMDGPU-PRO :/

[edit] I found why i have this problems. W5130m is in fact Cape Verde (like HD8800m). Thats why linux finds my GPU as Radeon HD8800m. Because of that fglrx for W5130m doesn't work. I can't install fglrx for HD8800m (also i'm afraid that it can damage W5130m) because for HD8800m is AMDGPU-PRO. But AMDGPU-PRO doesn't support W5130m, which i have....

I'm asking questions only for Ubuntu 16.04. I want to fix this on Ubuntu 16.04 (or higher).

    root@****:~# lshw -C display
  *-display                 
       description: Display controller
       product: Venus LE [Radeon HD 8830M]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 87
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:127 memory:d0000000-dfffffff memory:ef200000-ef23ffff ioport:e000(size=256) memory:ef240000-ef25ffff
  *-display
       description: VGA compatible controller
       product: HD Graphics 530
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:126 memory:ee000000-eeffffff memory:c0000000-cfffffff ioport:f000(size=64) memory:c0000-dffff
  • It wasn't a question.... I was saying that i managed to install fglrx for my W5130m, but linux still didn't properly recognized my GPU. You can't even mention versions that reached end of life? Why? – Kiriki Oct 3 '17 at 20:38
  • Kali is also off-topic here. Your answer as to why is here: askubuntu.com/help/on-topic. These versions are on topic at our sister site unix.stackexchange.com you may wish to request migration of this question – Elder Geek Oct 3 '17 at 20:41
  • I'm not asking about Ubuntu 12 or kali. I'm just saying, that this error is the same on other systems, so reinstalling Ubuntu won't help (for example). I just want to point that this problem occurs on different distros. – Kiriki Oct 3 '17 at 20:44
  • 1
    @Kiriki Elder Geek is just asking that you please limit the question to only include things that are on topic for the site. – dobey Oct 3 '17 at 20:47
  • @dobey, i'm asking how to fix this on Ubuntu 16.04 (or higher). I thought Ubuntu 16.04 is still supported (i think even 14 is supported till 2019). Also, i'm asking how to fix problem with AMDGPU-PRO which works only on Ubuntu 14 and 16... – Kiriki Oct 3 '17 at 20:49
1

Judging from this recent thread on Phoronix, it would seem your specific GPU does not have support from AMD yet in the Pro drivers, and you will need to use either fglrx on Ubuntu 14.04.1 (non-HWE stack) for now, or the open source radeon or amdgpu drivers on 16.04, until GCN 1 graphics gets proper support.

  • You are right :/ I missed that W5100 is supported, not W5100m :/ – Kiriki Oct 3 '17 at 21:09
  • Also, on link you posted i found that W5130m is Cape Verde (like HD8800m) underneath. HD8800m is supported by AMDGPU-PRO. I'm confused – Kiriki Oct 3 '17 at 21:26
  • Look at your lshw output again. It says 88*3*0M, not 8800M. – dobey Oct 3 '17 at 21:42
  • yeah, but they it is HD8800m family. HD8800m family contains 8830, 8850 and 8870. To better understand why 8830, 8850 and 8870 are basically the same card, you can read about silicon lottery. Ergo, if something refers to HD8800m, it refers to 8830, 8850 and 8870 amd.com/en-us/products/graphics/notebook/8700m-8800m# – Kiriki Oct 3 '17 at 21:58
  • Maybe try to blacklist the radeon module, to see if amdgpu will get picked up instead? – dobey Oct 4 '17 at 0:34
0

Ok, so i managed to install drivers for HD8800m on Ubuntu 14.04. Everything was fine, but i wanted to try Unigine heaven or valley to check if fglrx is worth the effort. Sadly, they were shutting down my computer (instantly, in milisecond). I tried to purge fglrx, and install different driver, but that broke whole system, so i have to install it all over again. any suggestion? Maybe it's known bug in unigine (i found no info about it)?

[edit] So, i managed to run unigine heaven with fglrx for minute or so, and i get somewhere around 15 fps (at the beggining). On other distro, i get ~20 FPS with Radeon driver. In conclusion, it's not worth it, i will stick with Radeon driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.