5

missing flash

In Linux ubuntu 16.04, When I open a page that uses or works with FLASH, nothing appears in the flash content and in the plugins everything is fine, flash is in mode (ACTIVATE ALWAYS) and nothing happens, before there was no problem, but in the update to version 56 this problem happens. Is there any solution???? I like to use Firefox and need flash. [Check The Image to can understand better what is happening]

I appreciate your help and your Answers!

PS: Sorry about the bad translate of english!

sudo dpkg -l adobe-flashplugin [sudo] password for jeisson: 

Deseado=desconocido(U)/Instalar/eliminaR/Purgar/retener(H) 
| Estado=No/Inst/ficheros-Conf/desempaqUetado/medio-conF/medio‌​-inst(H)/espera-disp‌​aro(W)/pendienTe-dis‌​paro 
|/ Err?=(ninguno)/requiere-Reinst (Estado,Err: mayúsc.=malo) 
||/ Nombre Versión Arquitectura Descripción  
+++-==============-============-============-===============‌​================== 
ii adobe-flashplu  1:20170912.1 amd64        Adobe Flash Player plugin

3

3 Answers 3

5

Both Adobe and Mozilla are in process of phasing out Flash support. By 2020, there will be no support from Adobe, and when security updates stop, Firefox will stop loading any version of the Flash Player. In the meantime, it appears you must enable Flash Player (aka Shockwave Flash) individually for each website where you want to use it. See the Mozilla announcement here.

The general recommendation is not to enable Flash unless a web site doesn't work without it, to "allow web sites to shine". Above that, I'd recommend contacting web admins to let them know you want to continue to enjoy their content, but that they urgently need to begin the process of converting from Flash to HTML. The 2020 Flash sunset will be here sooner than it seems.

7
  • Ok, i got it, it seems Flash is dead in Firefox, thanks for your answer! (Y) Oct 3, 2017 at 19:18
  • Flash is not dead in Firefox, but it defaults to "off" for all websites until you specifically turn it on for each specific website. Flash will be dead in less than three years, however, so it's time and past time to bury web admins in request to convert their content away from Flash.
    – Zeiss Ikon
    Oct 3, 2017 at 19:35
  • @JeissonCadena A new Firefox update arrived. Update and check whether it's working now. Working for me.
    – pomsky
    Oct 4, 2017 at 15:32
  • Flash is not dead and I have the same problem as @JeissonCadena. Ubuntu 16.04, Firefox 56 from today morning, Adobe Flash 27 with always active setting and no flash visible on any web pages. No messages in logs. Firefox 55 was working almost properly (bugzilla.mozilla.org/show_bug.cgi?id=1394015), Firefox 54 was working without any issues. So it is some kind of issue.
    – Martin
    Oct 5, 2017 at 18:29
  • OK, there were some new updates couple of minutes ago for Ubuntu 16.04 including some update for Firefox 56. And now it is working.
    – Martin
    Oct 5, 2017 at 19:14
1

Same problem since Firefox 56 (64 bits) in Ubuntu 17.10, I think is related to some workaround I applied from the lapse when Adobe dropped Flash Player support for Linux.

The solution is:

  1. Install Flash Player via the adobe-flashplugin package (perhaps you need to activate Cannonical's Partners repositories in Software and Updates).
  2. Run this command in terminal:

    sudo update-alternatives --config mozilla-flashplugin
    
  3. It'll show something like this (copy-paste from my case, I'm using spanish locales):

    Existen 2 opciones para la alternativa mozilla-flashplugin (que provee /usr/lib/mozilla/plugins/flashplugin-alternative.so).
    
    Selección   Ruta                                                                            Prioridad  Estado
    ------------------------------------------------------------
    * 0            /usr/lib/browser-plugin-freshplayer-pepperflash/libfreshwrapper-flashplayer.so   70        modo automático
     1            /usr/lib/adobe-flashplugin/libflashplayer.so                                     50        modo manual
     2            /usr/lib/browser-plugin-freshplayer-pepperflash/libfreshwrapper-flashplayer.so   70        modo manual
    
    Pulse <Intro> para mantener el valor por omisión [*] o pulse un número de selección:
    
  4. I selected the option that points to /usr/lib/adobe-flashplugin/libflashplayer.so, then, when I ran sudo update-alternatives --config mozilla-flashplugin the output was:

    Existen 2 opciones para la alternativa mozilla-flashplugin (que provee /usr/lib/mozilla/plugins/flashplugin-alternative.so).
    
    Selección   Ruta                                                                            Prioridad  Estado
    ------------------------------------------------------------
    0            /usr/lib/browser-plugin-freshplayer-pepperflash/libfreshwrapper-flashplayer.so   70        modo automático
    * 1            /usr/lib/adobe-flashplugin/libflashplayer.so                                     50        modo manual
    2            /usr/lib/browser-plugin-freshplayer-pepperflash/libfreshwrapper-flashplayer.so   70        modo manual
    
    Pulse <Intro> para mantener el valor por omisión [*] o pulse un número de selección:
    
  5. I rebooted and then Flash Player worked in Firefox Qantum.

1
  • This solution works on Ubuntu 18.04.2 LTS with Mozilla Firefox 65.0.1.
    – Arya
    Mar 1, 2019 at 4:54
0

Tested workaround solution for now.

  1. Head over to the official Firefox download page.
  2. Download the tar bzip package to your home directory.
  3. Extract so you have /home/username/firefox
  4. Make a shortcut on the desktop to Firefox, point it to /home/username/firefox/firefox

Enjoy flash until the official packages are updated.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.