0

I am running Ubuntu 17.04 and installed VLC as snap. But when I try to run vlc, I got this error message:

/snap/core/current/usr/lib/snapd/snap-confine: error while loading shared 
  libraries:  libudev.so.1: cannot open shared object file: No such file or
  directory

I checked ldconfig -p | grep libudev and this I have:

libudev.so.1 (libc6,x86-64) => /lib/x86_64-linux-gnu/libudev.so.1.

What can be a problem? I an new in this snap stuff.

  • Erase the folder manually and reinstall – user186255 Oct 3 '17 at 16:07
1

I ran into the same error while trying to install a package in 17.10, but it won't work for 17.10.

The only way to resolve this would be to run the snap package on Ubuntu 16.04 and then you'll be able to definitely run it.

Also, don't run it on a 16.04 live CD either. You'll be needing a system or a Virtual Machine with 16.04 installed on it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.