1

I have a problem on my old Toshiba Satellite A210 laptop (AMD Turion X2 TL-64 with ATI Radeon HD2600 and 4GB ram); assuming that with Ubuntu 14.04 everything works perfectly, testing any version between 16.04, 17.04 and 17.10beta, the system always hangs on shutdown or reboot, remaining locked on the logo and forcing me to hold down the power button to force it to poweroff. This happens with predefined kernels and even updating everything via synaptic.
I noticed that these errors are reported at Ubuntu startup:

[    0.092139] mce: [Hardware Error]: CPU 1: Machine Check: 0 Bank 0: ee4be1000001fbff
[    0.092144] mce: [Hardware Error]: TSC 0 ADDR fbffefcbfbff 
[    0.092147] mce: [Hardware Error]: PROCESSOR 2:60f82 TIME 1506928590 SOCKET 0 APIC 1 microcode 0
[    0.092151] mce: [Hardware Error]: CPU 1: Machine Check: 0 Bank 1: ffffffffffefcfdb
[    0.092152] mce: [Hardware Error]: TSC 0 ADDR ffffffffffffffff 
[    0.092155] mce: [Hardware Error]: PROCESSOR 2:60f82 TIME 1506928590 SOCKET 0 APIC 1 microcode 0
[    0.222219] ACPI Error: No handler for Region [ERAM] (ffffa0f02c0b3af8) [EmbeddedControl] (20160930/evregion-166)
[    0.222228] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20160930/exfldio-299)
[    0.222233] ACPI Error: Method parse/execution failed [\_SB.HTEV] (Node ffffa0f02c0aaaa0), AE_NOT_EXIST (20160930/psparse-543)
[    0.222241] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPC0.EC0._REG] (Node ffffa0f02c0b57d0), AE_NOT_EXIST (20160930/psparse-543)
[    0.222827] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored

After spending many hours searching for the problem, I found out that using the kernel version 4.4 (4.4.89 at this time) everything works well and startup errors disappear! If I use another version (the latest versions of 4.8, 4.9, 4.10, 4.12, 4.13), errors go back and the system hangs again on shutdown or reboot.
I also noticed that using the grub nolapic option, the system turns off properly, but the CPU is not recognized correctly (only 1 core detected) and there are lags using the system; noapic has no effect, but other acpi options (acpi = off or acpi = noirq and all other combinations) block the system at startup.
Now I'm using Ubuntu 17.10beta with the 4.4.89 kernel and everything works fine (support for kernel 4.4 should still last until 2022, https://www.kernel.org/category/releases.html).
Can anyone suggest how to proceed to try to resolve this issue with the latest kernel versions?

0

Just enter below commands it will become proper:

  1. dpkg --configure -a
  2. sudo apt-get update && sudo apt-get upgrade
  3. Reboot.
  • Thanks, but the problems persist – Almaster Oct 12 '17 at 19:33
0

I have same laptop as you and I'm facing the some issue.

Unfortunately Kernel 4.4 have another issue where the Bios screen freezes after a reboot (Shut down works well)

This was my last findings:

Whe the splash screen freezes, Instead of pressing the F2, i pressed F8 and i was able to boot in a liveusb of elementary.

Unfortunuly it got stuck on the "e" slpash screen and when i pressed a key it showed this message:

ata1: softreset failed (device not ...) ... can't open /dev/sr0: No medium found

Could be this that ubuntu are messing with that makes the spash screen freeze.

When i try a live usb with kernel 4.10 i see two failed messages before shut down or reboot freezes the computer:

[ Failed ] failed unmounting /rofs [ Failed ] failed unmouting /cdrom.mount.

The last message is:

[ Ok ] Reached target shutdown.

Thanks.

You can find my askubuntu question here

  • I have the same problems! The bios screen freezes on reboot. But after a clean install of Ubuntu 17.10 beta and after installation of kernel 4.4.89, restarting and shutdown work fine! Unfortunately i still found a lot of problems with wifi and bluetooth when i run ubuntu and then reboot in windows 10 with dual boot. It means there's really some serious problem with compatibility with all kernels. For me this laptop is great, but I think it will not work with current linux distributions even though it works fine with windows. I've already lost too much time, so i'll only use windows. – Almaster Oct 12 '17 at 19:58
  • Hi. Thanks for your reply. Do you also get the same errors in the situations described in my post? Have you tried this?: " forum.level1techs.com/t/ubuntu-16-04-hanging-on-reboot/112413 "This person seemes to have the same problem as us, but on a HP laptop. – Daisuke Jigen Oct 14 '17 at 11:47
0

If you still want to use Ubuntu 16.04 with the kernel 4.4, the problem is something related with the wireless connection.

Power-off works like it should, but if you reboot with the wireless enabled, when it gets to the BIOS screen (Toshiba splash screen) it freezes.

What I did was create a Systemd service that disable the wireless connection on the shut-down or reboot and enables on boot.

This is how I did it:

  1. Update your Ubuntu installation.

  2. Make an empty file named wireless-fix.service in /etc/systemd/system/ and copy the following text into this file:

    [Unit]  
    Description=Fix Wireless  
    After=network-online.target  
    
    [Service]  
    Type=oneshot  
    RemainAfterExit=true  
    ExecStart=/bin/sleep 5
    ExecStart=/usr/bin/nmcli radio wifi on
    ExecStop=/usr/bin/nmcli radio wifi off  
    
    [Install]  
    WantedBy=default.target  
    
  3. On the terminal run this commands:

    sudo systemctl daemon-reload
    sudo systemctl enable wireless-fix.service
    sudo systemctl start wireless-fix.service
    sudo systemctl daemon-reload
    
  4. Reboot the computer and it should be fixed.

  • Can you please edit your answer and reformat it? – Peshmerge Mar 13 '18 at 13:38
  • Could you give me some tips? I'm new to this. – Daisuke Jigen Mar 15 '18 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.