1

Message on Software Updater

Every time I open Software Updater to check for updates, I always got a message like this (You stopped checks for updates). After that, I got message "System problem detected". And every time I reboot the system, the pop up "System problem detected" always shows up. I've tried to delete the crash file by sudo rm /var/crash/*, but it always comes back.

  • Please open a terminal and run sudo apt update and then sudo apt full-upgrade. If any, please edit and post the error message in its entirety. – user692175 Oct 3 '17 at 9:25
  • I already run sudo apt-full upgrade but it shows no errors. It just says "0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded." – tangorboyz Oct 3 '17 at 9:27
  • Did you run sudo apt update first ? – Soren A Oct 3 '17 at 9:29
  • yes, I did run it. – tangorboyz Oct 3 '17 at 9:30
  • try sudo cat /var/log/apt/term.log or cat /var/log/apt/history and inspect any cause to this problem. Does sudo dpkg --configure -a helps? – Redbob Oct 3 '17 at 12:30
2

Run sudo pip3 install --upgrade pip setuptools wheel solved the problems. There must be an error because I use both python 3.5 and 3.6. The error must happened after I reinstall some python 3.6 package. Now the software-updater is working again. I got this from github https://github.com/Homebrew/homebrew-core/issues/3078 . There's also chardet package that lost from python 3.5 installation, that cause the package-downloader from update-notifier to crash. So I runsudo pip3 install --upgrade requests that also install chardet. https://stackoverflow.com/questions/31387799/importerror-cannot-import-name-chardet

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.