7

Until yesterday, doing CtrlAlt (or any other direction) would switch workspaces.

Today, even if workspaces are enabled (Settings>Appearance>Behavior hasn't changed, and also SuperS displays the workspaces wall), it doesn't work anymore. CtrlShiftAlt (or any other direction) doesn't work either. Clicking on the launcher icon of a program already open on a different workspace doesn't take me to that workspace (it doesn't do anything really).

Just to rule out problems with each of the keys, CtrlAltT (for summoning a Terminal) works, and the arrows work.

At the same time, these key combinations started having other effects depending on the program I'm using. In Gnome Terminal, they will print D, B, C, A (using CtrlAlt + , , , respectively). In Eclipse, the CtrlAlt+ either or will duplicate the current line.

I'm using Unity on Ubuntu 16.04 and I don't use any customization tool like gnome tweaks or ccsm: they were never even installed. My keyboard layout is English (UK) and always has been.

I'd like to know how to restore the expected behaviour, and possibly also what could have caused this, since I don't remember changing any setting from yesterday to today.


Edit: I've just tried to use workspaces on a guest session, and they work as expected (I can switch workspace using hotkeys). So the problem must be in my user's settings, even if I still can't think of anything I've done to trigger this.

What would be the smallest amount of configuration files I should backup and remove to see if normal behaviour is restored?

[[ Edit3: apparently neither removing.config nor .local fixes the issue! ]]


Edit2: the key shortcuts are still listed in Settings>Keyboard>Shortcuts but don't work. I've also tried the SuperHome alternative, but it doesn't work either.

enter image description here

It doesn't even work if using the on-screen keyboard!

20
  • 1
    Open your keyboard settings pane and check the keyboard shortcuts. It sounds like the control-alt-arrow have been deleted or changed. You can prove this if you can do control-alt-1 and switch to workspace 1... -2 for workspace 2, etc.
    – heynnema
    Oct 3 '17 at 23:02
  • 1
    The only thing to do then is to move other stuff out to the desktop, log out/in, retest, until you find the problem file/folder. Reinstalling the OS won't solve your problem, as the Guest account works. It's an account-specific problem.
    – heynnema
    Oct 5 '17 at 12:41
  • 1
    Reinstalling the OS won't solve your problem, as the Guest account works, as per your own testing. It's an account-specific problem.
    – heynnema
    Oct 5 '17 at 13:07
  • 1
    Thank you for checking. I still suspect im-config, but I don't know much about it (as we don't need it in our locale). It has a manpage. Maybe see if you can disable it completely for your user? To be clear, I'm out of my depth now and this is just speculation. Oct 6 '17 at 14:25
  • 1
    If you want a hatchet approach, open ~.config/dconf & rename user to user.bak Then immediately go ctrl+alt+F3, login, run reboot command. Then see if fixed, if so set up your preferences again. If not then you can go back to that folder, delete user, rename user.bak to user & do the tty3 thing again to go back
    – doug
    Oct 7 '17 at 12:14
3
+100

You can resolve this issue by using dconf-editor. It's available by first enabling the universe repository and then issuing the command sudo apt install dconf-editor After which you can launch it from the applications menu. See below for the relevant section:

enter image description here

Navigate in the left hand column down to wm, click the arrow that points to the right to expose and then select keybindings. Scroll down the right window to expose "move-to-workspace-down", select it and click the Set to Default button. This should set this binding to ['<Shift><Control><Alt>Down'] Repeat this process for the next 3 entries which correspond to left, right, and up. The changes should take effect immediately. If not, reboot.

kudos to @doug for this comment which pointed out the right place to look.

4
  • Thank you, I'll restore my backed up "user" file (I have replaced it with a new one as per doug's comment) and try this.
    – Nicola Sap
    Oct 10 '17 at 7:38
  • No problem. Always eager to help.
    – Elder Geek
    Oct 10 '17 at 13:04
  • I'm assigning the bounty so that it doesn't get "wasted", but I'll test it over the weekend. Thanks
    – Nicola Sap
    Oct 12 '17 at 8:58
  • Unfortunately, I have then reinstalled the system completely and lost the backups, so I can't test the solution.
    – Nicola Sap
    Oct 3 '18 at 9:00
1

This solution restored the functionality, although it threw the baby out with the bathwater and didn't help to identify the cause:

If you want a hatchet approach, open ~.config/dconf and rename user to user.bak

Then immediately go CtrlAltF3, login, run the reboot command.

doug

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.