2

I've been using VirtualBox for the first time to run Ubuntu and am having some problems with shared folders. I've done everything that I can think of after googling and looking around but still can't seem to find them anywhere.

  • I've added the user to "vboxsf"
  • I've installed the guest additions
  • I have permanent, Auto-Mount folders created on my host PC and shown in the "shared folders" at the top

However, I cannot find these folders anywhere on the guest OS that I can use to access and bring files across/share them with my normal windows OS.

Any help would be appreciated! Thanks!

1

Short Answer:

sudo apt-get install virtualbox-guest-utils

Long Answer:

I had the same problem.

Assuming that we have already added the shared folder in the virtual box:

{

1) Machine -> Settings -> Shared Folders

2) Click on the "Add new shared folder" icon

enter image description here

3) Choose the path for the host folder you want to share (for example "C:\hostFolder")

4) Give "Folder Name" a name (for example "sharedFolderName")

5) Check "Auto-mount"

}

However, after starting the VM, there was nothing in my /media/.

But as soon as I ran:

sudo apt install virtualbox-guest-utils

I could see the sh_ folder:

ls /media/

Although you can access the content of your host folder through media, I suggest creating another folder:

mkdir ~/guestFolder

and then:

sudo mount -t vboxsf sharedFolderName ~/guestFolder

Now you can see content of the host folder here:

ls ~/guestFolder

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.