My screen turns off after 30 seconds of inactivity since I installed 17.04.

I've tried so many ways to fix it, including xset s off and dpms but it hasn't helped. When I type xset q on terminal it gives me this:

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  33
  auto repeating keys:  00ffffffdffffbbf
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  5/1    threshold:  5
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Disabled

What should I do? Trying change things in settings doesn't work either. Thanks for the help in advance.

  • Did you see System Settings > "Brightness and lock" configuration? Maybe it's settled to turn monitor off after 30s. – Redbob Oct 3 '17 at 3:53
  • Sadly not, Brightness and lock set to "Never" and energy too. Problem still going =/ – Edu Oct 4 '17 at 4:01
  • I am not going to post this as an answer, because it's not directly solving the problem. The time you used so far figuring it out, you could possibly have used to re-install the system on your computer. Have you tried that? Another thing, have you tried connecting external devices such as mouses and keyboards (if a laptop? it's not specified). Other than that I would have no clue about this issue – Denny Dec 12 '17 at 22:15

I'm sorry that this won't fix your problem, but this is the first google result for 'ubuntu screen turning off after 30 seconds of inactivity' and I wanted to share that this problem happened to me on Ubuntu 16.04 after letting my laptop battery fully deplete and force shutdown, and the fix was:

xset -dpms

This answer is for anyone else that might be helped. Sorry OP.

  • @OP If you try enabling and disabling the dpms? would that solve your Issue? – Denny Dec 12 '17 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.