0

I have an executable file, that I create using Electron Packager, named "SteamCMD GUI".
When I attempt to double-click it, it won't execute, but Ubuntu tries to execute it using PyPar2.
Next, I typed in the terminal:

file SteamCMD\ GUI

Then I got the following:

SteamCMD GUI: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.26, BuildID[sha1]=8e66ed87010d0cb4ed7d7926d2dc454ea2561b5c, stripped

Which made me think that I can indeed execute the file, so I typed:

bash SteamCMD\ GUI

But, then I got the following error:

SteamCMD GUI: SteamCMD GUI: cannot execute binary file

How to solve this problem?
Thanks!

  • bash is for running shell scripts, not binary executables. Either place the file somewhere that's on your PATH, or provide a path to it (if the file is in the current directory, that's as simple as typing ./ before the name e.g. ./SteamCMD\ GUI) – steeldriver Oct 2 '17 at 23:21
  • Thanks for replying! When typing bash ./SteamCMD\ GUI, I get ./SteamCMD GUI: ./SteamCMD GUI: cannot execute binary file – avi12 Oct 3 '17 at 15:04
  • It seems I wasn't clear. Do not type bash at all - just ./SteamCMD\ GUI – steeldriver Oct 3 '17 at 16:09
  • Oh nice, that worked. Is there a way to launch it by double-clicking it instead? – avi12 Oct 3 '17 at 16:54
0

It turned out that I simply needed to give the executable the permissions it needed, so I typed in the terminal:

chmod +x SteamCMD\ GUI

And then everything worked perfectly - I could both execute it by double-clicking it, and by typing to the terminal ./SteamCMD\ GUI.

0

@steeldriver and @avi12 your answer worked for me as well. Thanks!

I am running Ubuntu 16.04LTS and added a script in my package.json so that I could run npm run package-linux from my source directory in terminal. The script in my package.json was

"package-linux": "electron-packager . electroyarn-app --overwrite --asar=true --platform=linux --arch=x64 --prune=true --out=release-builds"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.