0

I messed up super bad. I'll try to explain more or less what happened:

  • installed Windows in dual boot with Ubuntu 16.04 (yes, first mistake)
  • tried to reinstall grub using a LiveUSB and mounting/umounting partitions, had EFI errors and such. At some point I stopped seeing some partitions with fdisk -l
  • downloaded and used repair-boot-disk, stopped seeing anything else except the LiveUSB with fdisk -l. The fstab file doesn't contain any of my partition anymore
  • tried to mount data partition, had some message "wrong fs type, bad option, bad superblock", out of stress and impatience I tried the first command found after a research... "mkfs.ext4" on this partition. Oops.
  • downloaded and used TestDisk, but it only sees a "loop0" partition (around 500MB) and the LiveUSB, nothing from the actual HDD. Same for PhotoRec...
  • I can still see the partitions in /dev/
  • from Windows (still working), I managed to recover 8GB of data from the partition I used mkfs.ext4 on, but it's only some "$BlockBitmap.xxxx.bin", "$INodeBitmap.xxxx.bin", "$INodeTable.xxxx.bin", "$SuperBlock.xxxx.bin", etc. files.

Is there any way to fix this mess? Even partially?

  • No, there isn't. – user692175 Oct 2 '17 at 12:39
  • Reinstall Ubuntu and recover from your backup. – Andrea Lazzarotto Oct 3 '17 at 5:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.