8

With single-screen, Unity is fast in opening apps, switching between opened apps, etc.

When I use dual-monitor then i see considerable drop in performance in the above mentioned areas. Overall system performance comes down to a crawl. I opened the same apps when using both single and dual-monitor. Is it a know bug? I'm on 11.10.

  • FYI my laptop has 2gb RAM and it passed Unity 3d test. – subeh.sharma Jan 17 '12 at 3:55
2

If your laptop has an Intel N10 graphics chip, it may be this bug: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/830949.

If so, an easy way to test is to lower the resolution of the external display until the sum of horizontal resolutions totals less than 2048.

If it turns out to be that problem, you have several options. One is to arrange the screens vertically rather than horizontally (the idea is that everything must fit in a 2048x2048 matrix, so as long as your monitors don't add up to more than 2048 in either direction you should be fine.

The second option is to use Unity2d, which doesn't trigger this bug.

  • No, it is NVIDIA – subeh.sharma Jan 17 '12 at 4:08
  • Thanks! I had this issue, but even after reading this issue it took me ages to reconfigure since the GUI for rearranging the screens didn't work because of the slowness, and I just couldn't seem to reset settings using documented ways. Finally, I was able to use xrandr to set things right. So for other googlers: xrandr --output LVDS1 --pos 0x0 --output VGA1 --pos 0x900 - your display names and desired positions may differ, run just xrandr to get a list of what you have. – skagedal Apr 2 '15 at 7:22
0

I've had this issue with ATI Radeon X2100. Slow performance was with Unity in general, not only 3D. However GNOME did't work much faster anyway. After few other bugs I've changed to 10.04 LTS and there are no problems.

0

Try the below:

  1. Nvidia X server settings
  2. PRIME Profiles
  3. Intel (Power savings mode)
  4. Log out then back in.

This fixed the multimonitor issue where the second display was being slow. This worked because the Nvidia driver assumed I had a single monitor. The refresh rates were therefore out of sync with the hardware and this resulted in visible lag.

Bear in mind this will only work if Nvidia X server settings is reporting only one monitor, if it detects both correctly then it may be something else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.