8

I am using Dell XPS 13 9360 with Ubuntu 16.04. It does not have a HDMI slot, so I have a USB-C-to-HDMI adapter, which is then connected to my monitor: DELL S2240L.

In System Settings > Displays, I can see that the monitor is detected properly and is turned on. If I try to move my mouse cursor out of my laptop screen and into the external display area, I can see the cursor leaving my laptop screen. If I keep moving my cursor further away and try to move back, it takes some time to reappear onto my laptop screen, so there is even the display 'space' for the cursor to move to.

However, the monitor keeps saying "no signal" and therefore goes to power-saving mode. I am pretty sure that the adapter doesn't have a problem because the computer is detecting the monitor. The monitor also works fine when connected to a different (Windows) desktop.

Here is the result for running sudo lshw -C video :

*-display               
   description: VGA compatible controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 02
   width: 64 bits
   clock: 33MHz
   capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:286 memory:db000000-dbffffff memory:90000000-9fffffff ioport:f000(size=64) memory:c0000-dffff

and xrandr :

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 294mm x 165mm
   1920x1080     59.93*+
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   960x600       60.00  
   960x540       59.99  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   800x512       60.17  
   700x525       59.98  
   640x512       60.02  
   720x450       59.89  
   640x480       60.00    59.94  
   680x384       59.80    59.96  
   576x432       60.06  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  
DP-1 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 476mm x 267mm
   1920x1080i    60.00*   50.00    59.94  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
DP-2 disconnected (normal left inverted right x axis y axis)

Any suggestions/insights?

1
  • I use my Ubuntu 19.4 laptop with the same Monitor all the time. It worked for months; then I connected it to a beamer at another place. This worked. Comming back home, the problem you describe. My solution was simple but cumbersome. I switched the HDMI cable from my laptop to another laptop running windows 10. Then I used the specific screen duplication buttons on the F-keys and switched around a few times. Then the monitor showed the mirrored windows 10 screen again. Then I unplugged it from the windows laptop back in the ubuntu laptop again, and magic happened, it worked.
    – Mike
    Jun 5 '20 at 12:00
5

I had the same issue with a Dell XPS 13 9360 running Ubuntu 16.04 using a USB-C da200 adapter. Try setting the resolution of the second screen to something low, say 1440x900 or lower. If that makes the second screen work (as it did for me) then you're running into a bug with the adapter, detailed here:

https://bugs.freedesktop.org/show_bug.cgi?id=93578

Updating kernels solved the issue for me. I was on kernel 4.10.xx, upgrading to kernel 4.12.14 worked for me.

2
  • Thanks for that answer, really helped ! To complement it, I would add that in my case, allowing fractional scaling and reducing the scaling on the monitor that was not previously displaying allowed me to revert back to the high resolution and keep it displaying. Oct 22 '20 at 9:54
  • Omg this worked! I'm on 20.04 LTS, 5.4.0-70-generic kernel too, and for some reason this did it! USB-C to HDMI to DVI adapter as well.
    – Coburn
    Apr 15 at 3:55
2

I had the same problem. Only one monitor at the time was working. This partially solved my issue.

I tried to change the resolution of the monitor with the highest resolution to something smaller. This already made both of the monitors to work.

enter image description here

Then, I increased the resolution of the monitor. Unfortunately, I am still not able to make the bigger monitor work at full resolution (2560x1440) but only at 1920 x 1200. Indeed, when I switch to full resolution (2560x1440) the other monitor disappears.

1

I have the same problem...

Monitor says "no signal" but xrandr says it is connected...

If I tell xrandr make any sort of change (it must be a change) then the display is reset and it all comes back.

For example, have xrandr turn it off and on...

xrandr --output DP-1-1 --off
xrandr --output DP-1-1 --auto

However it losses its position information and just becomes a clone, until I again reset the position. Any windows on that display get moved to make them at least partially visible in the other display, though I have found it shift a LOT of windows which should not have been effected too. Basically it is a horrible fix.

This fixes the problem some of the time...

xset dpms force suspend # or standby or off (same result)
xset dpms force on

This is the best solution I found so far, but depends on your setup...

Move the display just a little (one pixel), then moving it back! It is enough of a change to get xrandr to resurect the monitor and does not cause my application windows to suddenly change position.

xrandr --output DP-1-2 --pos 1921x0;    # shift one pixel
xrandr --output DP-1-2 --pos 1920x0;    # shift it back
0

Try this and see if it works:

xrandr --output eDP-1 --mode 1920x1080 --output DP-1 --mode 1920x1080 --same-as eDP-1

and see if it works. That should create a mirror but that's exactly what we want to test first, we want to test whether mirroring works. Then we can move forward.

I've (literally) never had any luck in setting up my monitor setup the way I want from any graphical utility so I resorted to the command line via xrandr and I got it to work perfectly in my case.

1
  • That gives me xrandr: cannot find mode 1920x1080 (although that mode is listed for both displays...) Feb 25 '19 at 7:36
0

Unfortunately I have the same problem here, after instsalling the newest nvidia driver on my Omen15 laptop. By the way I only managed to install the driver sucsessfully when I disabled my secure boot.

My situation is exactly the same as yours, second monitor detected but not showing anything.

I have tried the following methods that I could find:

  • Changing the second/main monitor's resolution (using CLI and GUI)
  • Install vbetool via:

sudo apt-get install vbetool

  • To install all recommended drivers via:

sudo ubuntu-drivers autoinstall

And I did not try the following:

  • re-installing nvidia driver (it will make me even frustrated)

However, none of them worked for me.

A few days later, when I again swicthed back to my Ubuntu after working with my Win10, the second monitor works! Just like how it works under Windows!

I have no idea of this, but folks, hope this give you some light after the frastruation...

Cheers!

Not the answer you're looking for? Browse other questions tagged or ask your own question.