Before you go marking this as a dupe, I know about Ctrl+Shift+C and Ctrl+Shift+V

I try to use them, and it doesn't work. On one particular Ubuntu computer, normal copy paste commands do not work: They do not work locally, and they do not work via remote session.

My guess was that perhaps logging into a computer where these functions where acting normally, and logging in via ssh would bypass the issue. This was not the case. I still cannot gain this functionally, even though the Ubuntu PC I am using has functional copy and paste from the terminal.

So I am out of guesses.

How do I enable this? The affected computer runs Ubuntu MATE 16.04. The terminal is mate-terminal, except when I login via ssh, in which case it's Bash. Caja is the window manager.

  • 3
    "even thought the ubuntu pc I am using has functional copy paste from the terminal" ... I'm confused - is copy-paste working or not?
    – muru
    Oct 2, 2017 at 0:23
  • So the issue only affects SSH? How are you connecting SSH?
    – wjandrea
    Oct 2, 2017 at 0:42
  • 3
    Bash isn't a terminal. It's a shell, which runs inside a terminal.
    – wjandrea
    Oct 2, 2017 at 3:45
  • 1
    Have you tried selecting text and middle clicking?
    – 4mAstro
    Oct 2, 2017 at 7:26
  • 1
    Caja isn't a window manager - it's a file manager/browser (default on MATE). The default window manager on MATE is Marco (a fork of Metacity). I use MATE, and Ctrl+Shift+C/V have worked fine for me in mate-terminal throughout my time using MATE (in 16.04, 16.10, 17.04). cc @bodhi.zazen since you asked about this :)
    – Zanna
    Oct 2, 2017 at 20:37

5 Answers 5


There are different ways to mark/copy and paste in linux. One of them works in all terminal emulators that I know, including xterm.

1. The linux mark and paste method - 'middle clicking'

  • Mark the text, that you want to paste by pressing the left mouse button and move the mouse. (You can left click twice to mark a word or three times to mark a line.)

  • Move the mouse cursor to where you want to paste the text.

  • Press the middle button or scrolling wheel (like it were a button). If no middle button, press the left and right buttons at the same time.

    In a terminal window, the text will be pasted at the cursor position. This works in the same terminal window, in another terminal window as well as in other programs, for example Firefox and gedit.

2. A method that works in many but not all terminal windows

2.1 Via menus

  • Mark the text, that you want to paste by pressing the left mouse button and move the mouse.

  • Use a pull-down or right-click menu and select 'Copy' (to clipboard).

  • Move the mouse cursor to where you want to copy the text.

  • Use a pull-down or right-click menu and select 'Paste'

2.2 hotkey combination with ctrl

  • Mark the text, that you want to paste by pressing the left mouse button and move the mouse.

  • Press shift + ctrl + c to 'Copy' (to clipboard).

  • Press shift + ctrl + v to 'Paste' into another terminal window.

  • Press ctrl + v to 'Paste' into a normal GUI application program, for example Firefox or Gedit.

  • 2
    I upgraded to Ubuntu 17.10, one thing is the default x-manager changed from unity back to gnome. Now the copy-on-select no longer work, when I use middle button to paste, it pastes some other clipboard buffer. I am still looking for solutions.
    – fchen
    Jan 22, 2018 at 4:54
  • @fchen, pasting with middle-click works for me in 17.10, even with Wayland. My system is a fresh install. I know that there are some problems with 17.10 systems that are upgraded from previous versions.
    – sudodus
    Jan 22, 2018 at 7:04
  • I switched from ubuntu xorg to unity and it works now. From other searches, people reported the copy-to-select works for a period and then won't work for some reason until you reboot.
    – fchen
    Jan 23, 2018 at 4:41
  • @fchen I'm on 16.04 and I'm experiencing the same problem :/ May 15, 2018 at 14:28
  • 1
    Let us continue this discussion in chat.
    – sudodus
    May 16, 2018 at 17:08

Have you tried using Ctrl+Ins and Shift+Ins? I'm not sure about copying, but pasting works fine for me. Give it a try and EDIT your question if it doesn't work.

  • Thank you ! Shift + Ins works for me in Windows/Putty.
    – Suraj
    Jun 4, 2021 at 14:04
  • Oh yes, thanks! Works for me too in Xubuntu 20.04. Normally Ctrl-Shift-C and V would work but it seems that assigning Ctrl-Shift to changing keyboard layouts breaks those for me. Nice to have a ready-made alternative that's not about mousing around through menus.
    – Don Joe
    Mar 4 at 0:31

FWIW, I don't do much cutting & pasting in a terminal. Just typing. What are you up to that makes cutting important?

Copy/paste is provided by the terminal program, if at all. There is no general answer. Since you don't tell us which terminal emulator you use, we cannot help. If terminal has pull down menu (gnome terminal), you may get hints. I am almost sure there is no Ctrl+V in xterm or rxvt.

ALSO can get cut/paste from program you are running in terminal. Launch emacs in a terminal, cut is Ctrl+W and paste is Ctrl+Y.

The only general paste feature will come from the basic Linux OS. This works in a Virtual Terminal (Alt+Ctrl+F1) as well. Use the left button to highlight. Then middle click to paste. Action must happen with no clicks between. Middle click is a focus and paste in one step. I use that all the time.

Also possible to install a clipboard imitation, maybe find terminal to cooperate with it. Transfer text from one program to another.


The one settings that was disabled on my machine preventing middle click paste to work as usual:


You can edit this value either by using dconf-editor (UI) or by using the cli:

gsettings set org.gnome.desktop.interface gtk-enable-primary-paste true
  • How to enable that? Aug 20, 2019 at 5:57
  • just run at terminal
    – johndpope
    Sep 13, 2021 at 0:52

I think this can only be a placebo for all of those who do not get further even after looking at all of the commands of the answers.

I opened a test file in vim:

vi test

Then I pasted with all of the methods I know (and mentioned above). In i mode, I pasted from system clipboard with middle-mouse and shift-insert, which worked. In v mode, I also used "*p for the same thing which got cut slightly. And I tried some other registers: "1y, then "1p, same with 2. When I q! the file, I could use Ctrl+Shift+v again in the shell.

Again, this is not a solution since it would mean that there was a clipboard or a register of a clipboard that was unavailable for some reason - not likely. Much more likely is a mistake on my side.

Not the answer you're looking for? Browse other questions tagged or ask your own question.