2

In my Ubuntu I went to System Settings > Language support -> Install/Remove Languages and I just get English.

I tried sudo apt-get install language-pack-fr language-pack-gnome-fr language-pack-fr-base language-pack-gnome-fr-base as suggested in the answer to How can I install one language by command-line. For any language I try I get no success with this method.

enter image description here

Any ideas?

  • 2
    Weird. I have a whole huge list of them. Are you connected to the internet AND do you have the repositories up-to-date? – dadexix86 Oct 1 '17 at 19:17
  • Something is definitely off mine show a bunch of them! – George Udosen Oct 1 '17 at 19:22
  • 1
    Can you please open Language Support from terminal, i.e. the command gnome-language-selector, and click the "Install / Remove Languages..." button. Please show us - by editing your question - any messages which appeared in terminal. – Gunnar Hjalmarsson Oct 1 '17 at 19:54
  • Close voters. HowTo answer completed... – Elder Geek Oct 2 '17 at 22:54
  • @ElderGeek: Hmm.. The OP's problem, if I understand it correctly, is that only English is visible in the Installed Languages window. – Gunnar Hjalmarsson Oct 3 '17 at 1:11
2

It appears that the root cause of this issue is that /usr/share/language-selector/data/languagelist is missing or incomplete. This file can be found in the package language-selector-common. A quick peek at dpkg -l *language-selector* shows that the following should have been installed by default.

ii  language-selector-common    0.165.4            all                Language selector for Ubuntu
ii  language-selector-gnome     0.165.4            all                Language selector for Ubuntu

sudo apt install --reinstall language-selector-common will likely do the trick. If not you may need to purge and then reinstall with

sudo apt-get purge language-selector-common be aware that this approach will remove both language-selector-common and language-selector-gnome so we have to reinstall both of them with

sudo apt-get install language-selector-common language-selector-gnome

Open Language support from the dash:

langsupport

Click install/remove languages.

enter image description here

Scroll to the language you wish to install, tick the box and click apply changes.

enter image description here

Support for your chosen language will be installed:

Note that:

enter image description here

Now that you've installed the language in your system, each user (this means you) can select it as an option in text entry settings as shown below:

text entry

Hit the + button to bring up the menu as shown below:

AddFrench

Now you can select French as a text entry language.

SelectFrench

You may wish to also check the keyboard layout chart.

Tested on Ubuntu 16.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.