I was trying to run

sudo apt-get upgrade

in terminal today, and I received the message here encountered by OP

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)

As a solution, I ran both of Pensacola's commands in terminal. It didn't seem to do anything on my computer, so I restarted my computer. As normal, I faced the GRUB screen, and chose to log into Ubuntu. However, instead of the login menu disappearing and immediately followed by the Ubuntu load circle that then asks me to put in my password, the login menu just disappears and I am left at a gray screen. I'm not sure what is up though it certainly seems connected to what I ran before. Does anyone know how I can fix this?

Regarding my system, I have:

Processor: - AMD Ryzen 5 1500 X Quad-Core Processor x 8 - Graphics: GeForce GTX 1050 Ti/PCIe/SSE2 - Base system: Ubuntu 16.04.2 LTS 64-bit - GNOME Shell

  • Hmm, if you had clicked over to the duplicate answer you would have seen this warning about what you did: "This should be used as last resort. If you use this carelessly you can end up with a broken system. Please try the other answers before doing this." Perhaps you can boot into a live USB session and recreate the files you deleted. – Organic Marble Oct 1 '17 at 17:05
  • @OrganicMarble I keep seeing suggestions to delete this file in some answers and I think this is a bad idea, doing that can lead to read and write error after all that mechanism is there to do just that prevent multiple access to certain files and directories. – George Udosen Oct 1 '17 at 17:13
  • I completely agree! Deleting those files sounds like a real bad idea to me too. – Organic Marble Oct 1 '17 at 17:39
  • @OrganicMarble Yep, should've done more digging. Unfortunately I've little idea of how to recreate those files, but on the flip side I haven't really installed that many things on my machine just yet, so I have that going for me. – rpickmans Oct 1 '17 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.