0

Some time between my latest update of BIOS (while using Windows) and playing around with Boot Order (to use a LiveUSB), my grub menu went missing. Previously, I was able to repair GRUB menu this way:

  • Booting into Windows
  • Going to Advanced Startup options
  • Selecting my Ubuntu partition there
  • Getting advanced restart -> Seeing my GRUB menu.

Then, I was able to select Ubuntu OS, log in, run boot-repair and get my GRUB menu back.

However, now after going through the boot-repair process, I still can't get my dual-boot grub menu back. My laptop keeps loading right into Windows.

Additional info: I also checked that the Boot Order's set up in the same way it was before I used a LiveUSB, it didn't help. I also tried some other combinations - without success...

I have Ubuntu 16.04 and a pre-installed Windows 8.1 on my PC. Secure boot and Legacy mode are disabled... and here is what boot-repair gave me the last time I used it:

https://paste.ubuntu.com/25652485/

I also use Grub Customizer to change the order of OSes in grub menu, but as far as I can tell, it has no impact on grub menu disappearance in this particular case. When I use grub-repair, and make no changes via Grub Customizer, menu still does not come up.

What could be the reason of this problem and how can I fix it?

  • Fast boot is turned off, too. – 0lesya Oct 1 '17 at 11:47
1

EFI expects the default boot loader to be /efi/boot/bootx64.efi. Windows is particular about making sure it boots.

Fist off, from 8.1 on windows does not really shut down, it suspends to disk ( like a hibernate) so that it boots faster. second it changes EFI to make entry 0000 (windows) first in the boot order. You should turn off Fast Boot in Windows if dual booting.

One work around: rename grubx64.efi to bootx64.efi then replace the file efi/boot/bootx64.efi.This makes grub the default boot loader. Save the original efi/boot/bootx64.efi in the windows folder in case you want to replace it later.

second: When in ubuntu, use efibootmgr to delete all Windows and Ubuntu entries. and reboot your computer. Make sure the first system you boot into is ubuntu so that it is placed in entry 0000. then boot windows.

On some newer systems, OS selection is allowed if the default path is empty. Temprarily, move /efi/boot/bootx64.efi to another place to see if the EFI settings will let you select OS to boot.

PS: I did have an older system that refused to boot grub after a BIOS update. Installing grub to /dev/sda fixed it. This is considered an odd ball though. EFi shouldn't be looking at the MBR for a bootloader.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.