Yesterday I updated the SMPlayer to the 17.10.0 (revision 8701). After update I can not hear any sound. I tried all output drivers: ALSA, pulse, oss, jack, pcm, sdl and sndio but none of them works.

After that I did remove and purge smplayer* and removed .config/smplayer/ folder and reinstall SMPlayer but the problem still exists.

On the GNOME control panel>sound>Applications SMPlayer does not list there when it is open.

The weird thing is mpv media player has sound.

What went wrong on my SMPlayer? How can I fix it?

I'm Using: Ubuntu 16.04 GNOME

GNOME shell 3.18.5

up vote 1 down vote accepted

SMPlayer 17.10 has stopped using some video and audio filters that have been deprecated in recent versions of mpv, and now it uses new ones. Unfortunately the version of mpv in Ubuntu 16.04 is very old and doesn't have some of the new filters.

Solution 1: update mpv

Solution 2: go to the SMPlayer preferences and turn off the audio equalizer and the volume normalization options. And don't use any of the audio filters from the audio menu.

  • Solution 3: Download version 17.10.2
  • New option in Preferences -> Network to select the preferred quality for streaming sites such as DailyMotion, Vimeo and so on (all those which are handled by youtube-dl).
  • The audio equalizer is now disabled by default on Linux to prevent a no sound problem for users with old versions of mpv.
  • Fix some problems with the letterbox filter (the 'add black borders' option).
  • The HDPI support is now also enabled on the portable package for Windows. Fix: now the time is correctly displayed in the thumbnail generator pictures when SMPlayer is built with Qt 5.

The above did not work for me with SMPlayer 18.6.0. So what I did is:

  • Remove and purge SMPlayer by running in terminal: sudo apt-get --purge remove smplayer

and do the same with MPV and MPlayer.

  • Find if they are any other files related to SMPlayer: sudo find / -name smplayer

and again do the same for MPV and MPlayer.

  • Go to directories where the left over has been found and delete them manually.
  • Reboot.
  • Reinstall the latest version of SMPlayer that you have downloaded.

At this point the sound should be back but there will be some other problems. So:

  • Reinstall MPV (no need to use the latest version (mine is: 0.14.0)): sudo apt-get install mpv

and do the same with MPlayer.

If this answer was useful for you, click the up arrow ^.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.