1

I just did a fresh install of Ubuntu 16.04 (16.04.3 LTS), x86_64, from a USB iso, on an Acer Aspire 5749.

Firefox works, but Chromium-browser doesn't launch. If I click the sidebar icon, it just keeps glowing but nothing happens. If I launch from terminal, I get a few error messages and the process stays open, but no windows appear, just the glowing icon on the sidebar.

The output from terminal is:

martin@martin-Aspire-5749:~$ chromium-browser 
[1:12:0930/125737.722024:ERROR:adm_helpers.cc(62)] Failed to query stereo recording.
[2948:2981:0930/125755.876517:ERROR:connection_factory_impl.cc(386)] Failed to connect to MCS endpoint with error -137
[2948:2981:0930/125845.818562:ERROR:connection_factory_impl.cc(386)] Failed to connect to MCS endpoint with error -137
[2948:2981:0930/125948.150181:ERROR:connection_factory_impl.cc(386)] Failed to connect to MCS endpoint with error -137
[2948:2948:0930/130026.393156:ERROR:account_tracker.cc(328)] OnGetTokenFailure: Connection failed (-137).
[2948:2948:0930/130026.393226:ERROR:account_tracker.cc(328)] OnGetTokenFailure: Connection failed (-137).

At some point I made it work by renaming the directory ~/.config/chromium to chromium-old so that a new one is created, then I renamed chromium-old to chromium again and it kept working perfectly, also from the sidebar icon, so I thought I had fixed it, but then on the next reboot it failed again, and renaming that directory didn't help.

I did an apt remove --purge chromium-browser, then installed it again, and again the trick of renaming the config/chromium directory (so that a new one is created) worked, but then it failed again after the next reboot, and now I can't make it work a third time, even after renaming (or deleting) the .config/chromium directory and reinstalling Chromium. I'm at a loss.

BTW, Google Chrome also has this problem. I uninstalled it because I prefer Chromium.

What can I do? Is this the right place to ask? Thanks in advance!

  • I don't see same in Ubuntu 17.04. If I were in 16.04, I would try what you did. Then I would rebuild Chromium from the source package. I had to do that in RHEL 7.4 last week and it took about 4 hours, 1700 files had to compile. That may help because it eliminates mismatch in libraries. The binary chromium you have may not be aware of the libraries you actually have. Chromium is such a huge thing, but it seems really sensitive to changes in support libraries. – pauljohn32 Oct 1 '17 at 9:33
  • To get idea of library problem, run 'ldd /usr/bin/chromium-browser'. Seems certain to me that one library has been altered and it is needed by both browser binaries you tried. ldd may show missing library. – pauljohn32 Oct 1 '17 at 9:37
  • Thanks for your help. I think it might be related to the graphics drivers, because glxgears does the same thing (the window doesn't open). I'll try another Ubuntu version and see what happens, too bad it's not LTS. – Martin OB Oct 1 '17 at 16:59
0

I haven't been able to find any "sure" solution but some recommend starting Chromium with software graphics rendering using chromium-browser --disable-gpu

Are there any crash reports in:

~/.config/chromium/Crash Reports ?

Information on advanced debugging for Chromium:

https://chromium.googlesource.com/chromium/src/+/lkcr/docs/linux_debugging.md

https://groups.google.com/a/chromium.org/forum/#!topic/chromium-dev/CzbTlWAQEEc

I suggest filing a bug report if you are unable to find a solution easily:

https://support.google.com/chrome/answer/95315?hl=en

  • Thanks for your answer. There are no Crash Reports in that directory. "disable-gpu" doesn't fix the problem. That link about Chrome crash reports recommends to do it from Chrome, but I can't open Chrome, so I can't do it that way. – Martin OB Sep 30 '17 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.