59

How can I set Google Chrome as the default browser? If I set it in the browser settings, nothing happens. The browser says it's default, but in preferred applications in Gnome, there's only Firefox to choose from. Clicking any link i.e in Thunderbird opens a blank Firefox window, not with the link embedded. Can I set the default browser in dconf2 or any configuration file?

  • 4
    Have you tried setting the default browser via System Info->Default Applications->Web? – TreefrogInc Jan 17 '12 at 3:34
59

Assuming you are using Unity, click on the dash button in the launcher and search for 'System info'. Then, open 'System info' and move to 'Default applications' section. Then, click on the dropdown list next to Web. There, select 'Google Chrome' and it will be selected as the default web browser for your system.

enter image description here

| improve this answer | |
  • 4
    Oh well! I was looking for this myself! They really got away with hiding and removing settings in this Ubuntu version, I thought Default Applications was removed! In Gnome Shell you can access it through System Settings > System Info > Default Applications. – Severo Raz Jan 17 '12 at 22:38
  • 3
    why is chrome not in the list for me ? – Ced Nov 15 '15 at 23:14
  • 3
    I have this, still Firefox opens as default. – Bugs Buggy Apr 13 '19 at 8:09
44

You should have in the ~/.config/mimeapps.list file the following lines:

text/html=google-chrome.desktop
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/about=google-chrome.desktop
x-scheme-handler/unknown=google-chrome.desktop

Make sure these lines are under either the [Default Applications] or [Added Associations] section.

And of course, you need google-chrome installed such that google-chrome.desktop is either located at /usr/share/applications/, /usr/local/share/applications/ or ~/.local/share/applications/.

| improve this answer | |
30

Alternatively, you can do the following instead of editing mimeapps.list:

xdg-mime default google-chrome.desktop text/html
xdg-mime default google-chrome.desktop x-scheme-handler/http
xdg-mime default google-chrome.desktop x-scheme-handler/https
xdg-mime default google-chrome.desktop x-scheme-handler/about

To check the current settings, you can use:

xdg-mime query default text/html
xdg-mime query default x-scheme-handler/http
xdg-mime query default x-scheme-handler/https
xdg-mime query default x-scheme-handler/about
| improve this answer | |
  • Thank! Setting these to exo-web-browser.desktop helped me a lot. – Remco Haszing Nov 26 '14 at 19:41
  • 1
    Works for applications that are not available in the drop-down list of the settings dialog – vitaly Sep 12 '15 at 2:51
  • this works when I click on a url in a terminal or within vim/mutt – user3865083 Aug 17 '19 at 10:09
13

There are a number of places an application might figure out which browser to launch and unfortunately there is no established standard. If the other answers don't work for you (as was the case for me with Skype) you could try:

  • the $BROWSER environment variable
  • /usr/bin/x-www-browser, which is configured via the alternatives mechanism: sudo update-alternatives --config x-www-browser (which is what Skype is launching it seems)
| improve this answer | |
  • I have the following when I enter this command. Any idea what the difference between "auto mode" and "manual mode" is? There are 2 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser). Selection Path Priority Status ------------------------------------------------------------ * 0 /usr/bin/google-chrome-stable 200 auto mode 1 /usr/bin/firefox 40 manual mode 2 /usr/bin/google-chrome-stable 200 manual mode – flickerfly May 2 '14 at 16:58
  • 1
    From the manpage: Each link group is, at any given time, in one of two modes: automatic or manual. When a group is in automatic mode, the alternatives system will automatically decide, as packages are installed and removed, whether and how to update the links. In manual mode, the alternatives system will retain the choice of the administrator and avoid changing the links (except when something is broken). – kynan May 2 '14 at 18:07
4

There are also the /etc/alternatives/ where you have links:

  • gnome-www-browser ->
  • x-www-browser ->

In my case Lotus Notes opened wrong browser using the link gnome-www-browser.

| improve this answer | |
1

In Ubuntu 18.04 and later select Settings -> Details -> Default Applications.

enter image description here

| improve this answer | |
1

For Kubuntu 20.04 with Plasma, you can do the following:

  1. Open the "Application Launcher"
  2. Type "Default Applications" into the searchbox
  3. You should see a system settings module with a star as an icon. It should actually says "Default Applications". Select it and open it
  4. Select the option "Web Browser" and from there just choose "Google Chrome" as the default app for opening http and https URLs
  5. Click "Apply" in order to save the settings

See the preview at the following screenshot of the default applications utility.

Alternatively, you can do this from the "System Settings > Applications (under Personalization) > Default Applications"

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.