0

I recently had to reinstall Windows and Ubuntu after a Windows Update wrecked everything. I'm more or less back up and running, but a shared hard drive is giving me problems. The drive works fine in Windows, but in Ubuntu it prevents me from changing the files (though I can still read them).

The file system on the drive is NTFS which might be part of the problem, but it also tells me that I don't have ownership of the drive.

Commands like this don't help:

sudo chown yourusername: /media/mountpoint

Or this (changing permissions with the Nautilus GUI)

gksudo nautilus

I have used the following command, when the drive is unmounted, in a fashion that gives me read-write access:

sudo mount -t ntfs-3g -o user /dev/sdb1 /media/Elements

But it's not persistent, I'll have to do this every time and that's cumbersome!

Any suggestions? Can I wrest ownership back of the drive? Is there an option to save the mount user option above so it's that way every time?

I'm tempted to follow the directions about editing my fstab based on this link

Links I got resources from:

https://ubuntuforums.org/showthread.php?t=1840948

External drive mounts only as root

2
  • Disable Fast Startup in Windows. If you disabled it before the update re-enabled it. – user692175 Sep 30 '17 at 10:40
  • That's been done... with still now change to the ownership problem. I'm wondering if the previous version of Linux I had on that machine before the wipe is causing this. Linux Mint 18 was the previous. – Jason Mehmel Sep 30 '17 at 15:51
0

I did use the option of editing the fstab, from the Disks utility in Ubuntu 17.04. (I found my info here.)

It's in the screenshot, but I'll also post my entry to the fstab for reference:

defaults,auto,uid=1000,gid=1000,umask=000,nls=utf8,x-gvfs-show 0 0

I opted for the umask=000 which might be too permissive, but since I have other users using this drive (logging into the same machine as their own users) I didn't want to accidentally lock it for them.

I'm not sure if the uid, gid, or umask made the difference; I had already applied ntfs-g using the Disks utility with no change to the problem, so I'm assuming it was a legacy user issue from when I had to reinstall windows and Linux.enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.