20

Everytime I touch the screen, even in a non text entry area, this keyboard pops out. How can I disable it? It is very jarring

6
15

This is a known bug. Please mark yourself affected here.

It's been a problem since 2015: see on redhat, on GNOME bugzilla, and now on gitlab.

Florian made some patches in 2017, but I don't know how to apply them. Hence my as-of-yet unanswered question.

In the meantime, this guy made a GNOME extension to kill Caribou

5
  • You apply them to the gnome-shell source & rebuild. Best choice for most users is to hope the patches are accepted & then you'll see in 18.04. The idea that 17.10 is for everyday use is misguided..
    – doug
    Oct 23 '17 at 2:18
  • Would you please explain how to patch in detail on askubuntu.com/questions/965598/…?
    – Tom Mercer
    Oct 23 '17 at 2:34
  • Also, 17.10 is for everyday use. Your claim that it's misguided is bold. Please provide evidence to support your bold claim, or accept the consensus that 17.10 is for everyday use.
    – Tom Mercer
    Oct 23 '17 at 4:14
  • Is there some "Just do it" solution?
    – Paul
    Feb 5 '19 at 14:15
  • Does the GNOME extension to "block caribou" not qualify?
    – Tom Mercer
    Feb 5 '19 at 23:49
12

To switch off the keyboard

  1. Click the "Universal Access" icon in the top-right action bar.
  2. Click the "Screen Keyboard" to "Off"
  3. The "Universal Access" icon will disappear if no other options are "on". See below if you want to switch the keyboard on and off more easily and quickly!

enter image description here

To switch keyboard on when the Universal Access Bar is unavailable

  1. Go to Settings -> Universal Access
  2. Set "Screen keyboard" switch to "On"

enter image description here

To force the the Universal Access bar to always be available

  1. Go to Settings -> Universal Access
  2. Set "Always show Universal Access Menu" switch to "On"

enter image description here It's unfortunate that there's no "Only when no other keyboard is available" option yet. Hopefully that will come soon. The Gnome version is far more tablet-friendly than Unity. :-)

4
  • @tom-mercer I wouldn't have answered it if I hadn't tested it! Works on the version of 17.10 I installed on Friday! Oct 23 '17 at 22:30
  • 1
    Turn off the keyboard in UA. Now touch your screen- drag, change windows, scroll, etc. What happens?
    – Tom Mercer
    Oct 23 '17 at 22:49
  • Yeah, gnome3 is tablet friendly, too bad that tablets are a single digit percentage minority while all the rest of desktop users have to suffer such usability issues. As far as I am concerned because of the hardcoded primary screen "feature" Gnome3 is pretty useless on multi-screen setups, where Unity was the best availabe option. Mar 30 '18 at 17:48
  • 3
    I'm on 18.04 and sometimes the keyboard gets "stuck" on the screen. If I go into Universal Access, the setting is "off". If in turn it "on" and then "off" again, the keyboard goes away. I'd really like to nerf it permanently. Jul 2 '19 at 17:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.