0

I have built in intel graphics that I want to use for my display, and keep my nvidia card for non-graphics workloads. After installing nvidia drivers (384.90), I get a boot loop after trying to log in. My monitor is plugged into the intel graphics output.

This is on a desktop with a PCIx nvidia graphics card.

syslog shows

Sep 29 15:17:04 machine org.a11y.atspi.Registry[4934]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Sep 29 15:17:04 machine gnome-session[4924]: Xlib:  extension "GLX" missing on display ":0".
Sep 29 15:17:04 machine gnome-session[4924]: gnome-session-is-accelerated: No hardware 3D support.
Sep 29 15:17:04 machine gnome-session[4924]: Xlib:  extension "GLX" missing on display ":0".
Sep 29 15:17:04 machine gnome-session[4924]: gnome-session-check-accelerated: Helper exited with code 256
Sep 29 15:17:04 machine gnome-session[4924]: gnome-session-binary[4924]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Sep 29 15:17:04 machine gnome-session-binary[4924]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Sep 29 15:17:04 machine dbus[826]: [system] Activating via systemd: service name='org.bluez' unit='dbus-org.bluez.service'
Sep 29 15:17:04 machine org.gnome.ScreenSaver[4797]: ** (gnome-screensaver:5024): WARNING **: Unable to get session bus: Failed to connect to socket /tmp/dbus-TNOEfmxdTg: Connection refused
Sep 29 15:17:04 machine org.gnome.ScreenSaver[4797]: ** (gnome-screensaver:5024): WARNING **: Failed to register with the message bus
Sep 29 15:17:04 machine lightdm[942]: ** (lightdm:942): CRITICAL **: session_get_login1_session_id: assertion 'session != NULL' failed
Sep 29 15:17:05 machine systemd[1]: Started Session c16 of user lightdm.
Sep 29 15:17:05 machine org.a11y.atspi.Registry[5069]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
1
  1. download and install nvidia drivers
  2. install drivers

    • press ctrl + alt + F2
    • log in
    • sudo systemctl stop lightdm.service
    • chmod +x NVIDIA-Linux-x86_64*
    • blacklist nouveau driver
    • sudo nano /etc/modprobe.d/blacklist.conf
    • append the following blacklist lbm-nouveau options nouveau modeset=0 alias nouveau off alias lbm-nouveau off
    • sudo update-initramfs -u
    • reboot computer
    • install nvidia driver
    • press ctrl + alt + F2
    • sudo systemctl stop lightdm.service
    • sudo ./NVIDIA-Linux-* --dkms --no-opengl-files
    • don't update your x config file when prompted
  3. install m4

    • sudo apt-get install m4
  4. download corresponding nvidia-modprobe from
  5. extract, compile, and install nvidia-modprobe

    • tar -xvf nvidia-modprobe-*
    • cd nvidia-modprobe-*
    • make all
    • sudo make install
  6. reboot computer

How to configure igpu for xserver and nvidia gpu for cuda?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.