2

I have a new Dell XPS 15 9560, which comes with Windows 10 Home 64-bit. I want to scratch that OS entirely and run Ubuntu 16.04.3 desktop amd64.

I use an external ASUS DVD, attached to USB3. From within Windows it works as expected, both to read and write.

However, booting with the proper Ubuntu image on the DVD encounters problems. I obtain the menu with four entries. Selecting either Try Ubuntu or Install Ubuntu brings up a screen with the word Ubuntu and a progress bar under it. Activity continues for a while, and then nothing more happens. If I started tty1 (ctrl+alt+F1) before it get stuck, I can see activity traces, which indicate errors like

ACPI exception AE_NOT_FOUND/while loading table
ACPI error 1 table load failure, 12 successful
DRM: failed to create kernel channel, -22. 

To get away from this, I have to do a hard reboot. The Windows system is not affected.

There are obviously a number of different parameters that might affect this behaviour, and I have made changes which appear ok, e.g. changing to SATA AHCI from RAID. Dell support have no answer, as it should suffice to press F12 during boot to select the DVD drive, provided it is enabled for boot in the BIOS.

How to possibly resolve this problem?

Continued research:

  1. Burnt the same 16.04.3 XPS AMD64 iso distribution to a USB memory, and attempted a new install. This time, Ubuntu appeared to install, granting all the questions required, but at the final "Reboot now" to complete the install, nothing happened, thus no reboot performed, although waiting a long time. Performed a hard reboot. At boot, the ubuntu boot option was there, but without being able to boot.

  2. Burnt ubuntu-17.04-desktop-amd64.iso to the same USB, and attempted a new install. This time, install completed, and the machine could be rebooted by clicking the "Reboot now" button. System booted and presented the login screen to logon as the administrator. Entering the appropriate password, followed by clicking on the arrow at the right end of the password field, resulted in only the background screen, no status line at the top of the window and no pointing device available. The only way out of this seems to be a hard shutdown.

  3. Left the laptop with a friend, who succeeded to install Ubuntu 17.04 desktop amd64. Most things appear to work now. There still are flaws (no exception messages, does not shutdown properly, some installs do not start after installation completed, installs using the Ubuntu install service might not run at all. Comments by friend: Seems to be two different graphics, NVIDIA and another. Currently additional driver in use is x.org.xserver - Nouveau display driver from xserver-xorg-video-nouveau. The NVIDIA binary driver, ver 375.66 from nvidia-375 not in use. Problems with graphics also seen in document: https://wiki.archlinux.org/index.php/Dell_XPS_15_9560.

In all cases, UEFI was used, secure boot was disabled, SATA mode changed from RAID to AHCI, and fastboot set to "thorough" in POST behavior. The machine used was Dell XPS 15 9560 with 32GB memory, 1TB SSD, and, as currently reported by Ubuntu 17.04 desktop:

Processor: Intel Core i7-7700 HQ CPU @ 2.80GHz x 8;

Graphics: Intel Kabylake GT2;

OS type: 64-bit;

Disk: 1TB;

To summarize, the problems encountered might be due to inappropriate graphics driver usage, although exact reasons are unknown.

0

1 Answer 1

2

I've had this problem and was just able to solve it, however, I can't guarantee if every step was necessary. Nevertheless, here's the flow that worked for me ;

  1. Install Ubuntu (I used 16.04) with USB key.

    1. When booting, press F12 to go in grub.
    2. Press e over Install Ubuntu.
    3. Add acpi=off after quiet splash
    4. Press F10 to launch boot.

    These steps should allow you to install Ubuntu without it 'hanging'. However, having acpi is not without consequences (e.g. uses a single core instead of 4 and reboot fails).

  2. Update Nvidia drivers

    1. Open Additional Drivers and check for drivers to install.
    2. In case of Nvidia, I had nvidia-384 available and installed it with sudo apt-get install nvidia-384, which then asked me to disable UEFI and reboot.
  3. Before reboot, I changed the grub file to add acpi=force.

    1. Run sudo nano /etc/default/grub
    2. Add acpi=force after quiet splash to obtain the line:

      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
      
    3. Press Ctrl+o to save and Ctrl+x to exit.

    4. Run sudo update-grub.
  4. Reboot the machine with reboot now.

So far, this worked for me. ACPI is enabled, can shutdown and boot without hanging. I am sure the process can be refined, but happy this worked for now.

1
  • On 18.04, instead of asking to disable UEFI, installing nvidia-384 prompts you to initiate some MOK thingy stuff on next reboot. If you do what it says, this solution also works for 18.04 with a Windows dual-boot setup.
    – flyx
    May 29, 2018 at 12:55

Not the answer you're looking for? Browse other questions tagged .