7

This is my Pictures folder. enter image description here The folders inside all contain photos. When I look at the settings app to change wallpapers, I get this. enter image description here

Why don't my photos appear in the "pictures" section?

  • Place them directory in the Pictures folder – George Udosen Sep 29 '17 at 18:01
  • If you are telling me to place one photo in the pictures file, I could do that, but I want all of my photos to appear in the settings app. – Justin15 Sep 29 '17 at 18:03
  • On going discussion, please be productive there: bugzilla.gnome.org/show_bug.cgi?id=712245 – Abdillah Jan 7 at 13:35
8

GNOME's background customisation option is very limited. Along with system background images and solid colours, it allows the user to choose images only from Pictures, not even from any subfolder of Pictures. You may do one on the following:

  1. Place the image you want to set as background in Pictures folder, not inside any subfolder.
  2. Recommended option: Use GNOME Tweak Tool to set images from wherever you like as your background image. Open the application and select your preferred image in Background Location option under Desktop. enter image description here
  3. Advanced option: Use dconf Editor to set any image as background. Open the application and navigate to /org/gnome/desktop/background/picture-uri, disable Use default value, and set the path to your image in the Custom value field.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.