0

I installed a minimal ISO of Ubuntu 16.04 (54 MB) on my virtual machine. After done installing the OS, I installed these programs:

  • open-box
  • lightdm
  • Qt
  • dokey

and some related libraries like "libgl1"

Everything works fine but when I did try to do the auto-login, I got stuck.

I have read many forums and watched a lot of videos, consequently found ways but none of them seems to work for me. The one which I'm eager to work with is lightdm.conf file:

sudo nano /etc/lightdm/lightdm.conf

In the file, first thing I did was to delete the guess and it worked fine but the rest of the code dose not work at all. I double checked my username using whoami:

[SeatDefaults] 
allow-guest=false
autologin-user=saeed
autologin-user-timeout=0
user-session=ubuntu

Since I am not using Unity, I did not write (but I did try the code before) this code:

greeter-session=unity-greeter

saeed is my only user now. However, I did try making another and do the auto-login with it, but the result was unsatisfying.

It's been around 12 hours of searching and trying. It seems that everybody is getting the result by above method, but I keep getting the login screen, I am afraid I might be short on some lib or something.

Since I am working on an embedded device (Intel based CPU, not ARM) it is crucial to get rid of the login in the main device (server) for the user behind LCD, nevertheless I do need the password for SSH connections security.

What can I do?

  • I've seen similar questions before which really haven't gotten a satisfactory answer. – Organic Marble Sep 29 '17 at 17:52
  • 1
  • I'd make sure the user-session is really ubuntu. Check the output of env | grep DESKTOP_SESSION. – mikewhatever Sep 29 '17 at 17:56
  • i did search for my desktops . it didnt work , i even tested on a fully Ubuntu . there is a post in ubuntuforums.org/… i did include pictures and more details – S2G Sep 29 '17 at 19:31
  • ok i didi change SeatDefault to [Seaat:*] and give delay 1 and delete the user session now the login screen is ***** . every second it crashes and resets a gain . so i can not even open the terminal using alt+ctrl+f1 . i think i have to start all over again . i wish i did get some backup . this is really annoying – S2G Sep 29 '17 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.