0

This error comes if I try to run apt-get install, apt-get autoremove, apt-get upgrade etc. commands.

I've added path for missing packages in my /etc/apt/sources.list file, but that didn't work.

Here's an example command that produces the error:

$ sudo apt-get install phpmyadmin php-mbstring php-gettext
Reading package lists... Done
Building dependency tree       
Reading state information... Done
php-gettext is already the newest version (1.0.11-2build1).
phpmyadmin is already the newest version (4:4.5.4.1-2ubuntu2).
php-mbstring is already the newest version (1:7.0+35ubuntu6.1).
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
24 not fully installed or removed.
Need to get 0 B/27.9 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
dpkg: error processing package libwayland-server0:amd64 (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
dpkg: dependency problems prevent configuration of libgbm1:amd64:
 libgbm1:amd64 depends on libwayland-server0 (>= 1.11.0); however:
  Package libwayland-server0:amd64 is not configured yet.

dpkg: error processing package libgbm1:amd64 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          dpkg: dependency problems prevent configuration of libegl1-mesa:amd64:
 libegl1-mesa:amd64 depends on libgbm1 (= 17.0.7-0ubuntu0.16.04.2); however:
  Package libgbm1:amd64 is not configured yet.
 libegl1-mesa:amd64 depends on libwayland-server0 (>= 1.11.0); however:
  Package libwayland-server0:amd64 is not configured yet.

dpkg: error processing package libegl1-mesa:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwayland-egl1-mesa:amd64:
 libwayland-egl1-mesa:amd64 depends on libegl1-mesa (= 17.0.7-0ubuntu0.16.04.2); however:
  Package libegl1-mesa:amd64 is not configured yet.

dpkg: error processing package libwayland-egl1-mesa:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwebkit2gtk-4.0-37:amd64:
 libwebkit2gtk-4.0-37:amd64 depends on libegl1-mesa (>= 7.8.1) | libegl1-x11; however:
  Package libegl1-mesa:amd64 is not configured yet.
  Package libegNo apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                         No apport report written because MaxReports is reached already
                                       No apport report written because MaxReports is reached already
                                                                                                     No apport report written because MaxReports is reached already
                   No apport report written because MaxReports is reached already
                                                                                 No apport report written because MaxReports is reached already
                                                                                                                                               No apport report written because MaxReports is reached already
                                                             No apport report written because MaxReports is reached already
                                                                                                                           No apport report written because MaxReports is reached already
                                         No apport report written because MaxReports is reached already
                                                                                                       No apport report written because MaxReports is reached already
                     No apport report written because MaxReports is reached already
                                                                                   l1-x11 is not installed.
  Package libegl1-mesa:amd64 which provides libegl1-x11 is not configured yet.
 libwebkit2gtk-4.0-37:amd64 depends on libwayland-egl1-mesa (>= 10.0.2) | libwayland-egl1; however:
  Package libwayland-egl1-mesa:amd64 is not configured yet.
  Package libwayland-egl1 is not installed.
  Package libwayland-egl1-mesa:amd64 which provides libwayland-egl1 is not configured yet.
 libwebkit2gtk-4.0-37:amd64 depends on libwayland-server0 (>= 1.2.0); however:
  Package libwayland-server0:amd64 is not configured yet.

dpkg: error processing package libwebkit2gtk-4.0-37:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gir1.2-webkit2-4.0:amd64:
 gir1.2-webkit2-4.0:amd64 depends on libwebkit2gtk-4.0-37 (>= 2.15.90); however:
  Package libwebkit2gtk-4.0-37:amd64 is not configured yet.

dpkg: error processing package gir1.2-webkit2-4.0:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency prNo apport report written because MaxReports is reached already
                                                                                 No apport report written because MaxReports is reached already
                                                                                                                                               No apport report written because MaxReports is reached already
                                                             No apport report written because MaxReports is reached already
                                                                                                                           No apport report written because MaxReports is reached already
                                         No apport report written because MaxReports is reached already
                                                                                                       No apport report written because MaxReports is reached already
                     No apport report written because MaxReports is reached already
                                                                                   No apport report written because MaxReports is reached already
 No apport report written because MaxReports is reached already
                                                               oblems prevent configuration of libqt5gui5:amd64:
 libqt5gui5:amd64 depends on libegl1-mesa (>= 7.8.1) | libegl1-x11; however:
  Package libegl1-mesa:amd64 is not configured yet.
  Package libegl1-x11 is not installed.
  Package libegl1-mesa:amd64 which provides libegl1-x11 is not configured yet.
 libqt5gui5:amd64 depends on libgbm1 (>= 8.1~0); however:
  Package libgbm1:amd64 is not configured yet.

dpkg: error processing package libqt5gui5:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt5widgets5:amd64:
 libqt5widgets5:amd64 depends on libqt5gui5 (>= 5.5.0) | libqt5gui5-gles (>= 5.5.0); however:
  Package libqt5gui5:amd64 is not configured yet.
  Package libqt5gui5-gles is not installed.

dpkg: error processing package libqt5widgets5:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt5opengl5:amd64:
 libqt5opengl5:amd64 depends on libqt5gui5 (>= 5.2.0); however:
  Package libqt5gui5:amd64 is not configured yet.
 libqt5opengl5:amd64 depends on libqt5gui5 (>= 5.3.0) | libqt5gui5-gles (>= 5.3.0); however:
  Package libqt5gui5:amd64 is not configured yet.
  Package libqt5gui5-gles is not installed.
 libqt5opengl5:amd64 depends on libqt5widgets5 (>= 5.3.0); however:
  Package libqt5widgets5:amd64 is not configured yet.

dpkg: error processing package libqt5opengl5:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt5printsupport5:amd64:
 libqt5printsupport5:amd64 depends on libqt5gui5 (>= 5.3.0) | libqt5gui5-gles (>= 5.3.0); however:
  Package libqt5gui5:amd64 is not configured yet.
  Package libqt5gui5-gles is not installed.
 libqt5printsupport5:amd64 depends on libqt5widgets5 (>= 5.3.0); however:
  Package libqt5widgets5:amd64 is not configured yet.

dpkg: error processing package libqt5printsupport5:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwebkit2gtk-4.0-37-gtk2:amd64:
 libwebkit2gtk-4.0-37-gtk2:amd64 depends on libwebkit2gtk-4.0-37 (= 2.16.6-0ubuntu0.16.04.1); however:
  Package libwebkit2gtk-4.0-37:amd64 is not configured yet.
 libwebkit2gtk-4.0-37-gtk2:amd64 depends on libegl1-mesa (>= 7.8.1) | libegl1-x11; however:
  Package libegl1-mesa:amd64 is not configured yet.
  Package libegl1-x11 is not installed.
  Package libegl1-mesa:amd64 which provides libegl1-x11 is not configured yet.
 libwebkit2gtk-4.0-37-gtk2:amd64 depends on libwayland-egl1-mesa (>= 10.0.2) | libwayland-egl1; however:
  Package libwayland-egl1-mesa:amd64 is not configured yet.
  Package libwayland-egl1 is not installed.
  Package libwayland-egl1-mesa:amd64 which provides libwayland-egl1 is not configured yet.
 libwebkit2gtk-4.0-37-gtk2:amd64 depends on libwayland-server0 (>= 1.0.2); however:
  Package libwayland-server0:amd64 is not configured yet.

dpkg: error processing package libwebkit2gtk-4.0-37-gtk2:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwebkitgtk-3.0-0:amd64:
 libwebkitgtk-3.0-0:amd64 depends on libegl1-mesa (>= 7.8.1) | libegl1-x11; however:
  Package libegl1-mesa:amd64 is not configured yet.
  Package libegl1-x11 is not installed.
  Package libegl1-mesa:amd64 which provides libegl1-x11 is not configured yet.

dpkg: error processing package libwebkitgtk-3.0-0:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of qml-module-ubuntu-web:amd64:
 qml-module-ubuntu-web:amd64 depends on libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2); however:
  Package libqt5gui5:amd64 is not configured yet.
  Package libqt5gui5-gles is not installed.

dpkg: error processing package qml-module-ubuntu-web:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of signon-ui-x11:
 signon-ui-x11 depends on libqt5gui5 (>= 5.2.0) | libqt5gui5-gles (>= 5.2.0); however:
  Package libqt5gui5:amd64 is not configured yet.
  Package libqt5gui5-gles is not installed.
 signon-ui-x11 depends on libqt5widgets5 (>= 5.2.0); however:
  Package libqt5widgets5:amd64 is not configured yet.

dpkg: error processing package signon-ui-x11 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of signon-ui:
 signon-ui depends on signon-ui-x11 | ubuntu-system-settings-online-accounts (>= 0.4); however:
  Package signon-ui-x11 is not configured yet.
  Package ubuntu-system-settings-online-accounts is not installed.

dpkg: error processing package signon-ui (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of webbrowser-app:
 webbrowser-app depends on libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2); however:
  Package libqt5gui5:amd64 is not configured yet.
  Package libqt5gui5-gles is not installed.
 webbrowser-app depends on libqt5widgets5 (>= 5.0.2); however:
  Package libqt5widgets5:amd64 is not configured yet.
 webbrowser-app depends on qml-module-ubuntu-web (= 0.23+16.04.20161028-0ubuntu2); however:
  Package qml-module-ubuntu-web:amd64 is not configured yet.

dpkg: error processing package webbrowser-app (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of webapp-container:
 webapp-container depends on libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2); however:
  Package libqt5gui5:amd64 is not configured yet.
  Package libqt5gui5-gles is not installed.
 webapp-container depends on libqt5widgets5 (>= 5.0.2); however:
  Package libqt5widgets5:amd64 is not configured yet.
 webapp-container depends on qml-module-ubuntu-web (= 0.23+16.04.20161028-0ubuntu2); however:
  Package qml-module-ubuntu-web:amd64 is not configured yet.
 webapp-container depends on webbrowser-app (= 0.23+16.04.20161028-0ubuntu2); however:
  Package webbrowser-app is not configured yet.

dpkg: error processing package webapp-container (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-core:
 xserver-xorg-core depends on libegl1-mesa | libegl1; however:
  Package libegl1-mesa:amd64 is not configured yet.
  Package libegl1 is not installed.
 xserver-xorg-core depends on libgbm1 (>= 8.1~0); however:
  Package libgbm1:amd64 is not configured yet.

dpkg: error processing package xserver-xorg-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-video-amdgpu:
 xserver-xorg-video-amdgpu depends on libgbm1 (>= 8.1~0); however:
  Package libgbm1:amd64 is not configured yet.
 xserver-xorg-video-amdgpu depends on xorg-video-abi-20; however:
  Package xorg-video-abi-20 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-20 is not configured yet.
 xserver-xorg-video-amdgpu depends on xserver-xorg-core (>= 2:1.17.99.902); however:
  Package xserver-xorg-core is not configured yet.

dpkg: error processing package xserver-xorg-video-amdgpu (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-video-intel:
 xserver-xorg-video-intel depends on xorg-video-abi-20; however:
  Package xorg-video-abi-20 is not installed.
  Package xserver-xorg-core which provides xorg-video-abi-20 is not configured yet.
 xserver-xorg-video-intel depends on xserver-xorg-core (>= 2:1.17.99.902); however:
  Package xserver-xorg-core is not configured yet.

dpkg: error processing package xserver-xorg-video-intel (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of appmenu-qt5:
 appmenu-qt5 depends on libqt5gui5 (>= 5.5.0) | libqt5gui5-gles (>= 5.5.0); however:
  Package libqt5gui5:amd64 is not configured yet.
  Package libqt5gui5-gles is not installed.
 appmenu-qt5 depends on libqt5widgets5 (>= 5.0.2); however:
  Package libqt5widgets5:amd64 is not configured yet.

dpkg: error processing package appmenu-qt5 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of shotwell:
 shotwell depends on libwebkit2gtk-4.0-37 (>= 2.15.1); however:
  Package libwebkit2gtk-4.0-37:amd64 is not configured yet.

dpkg: error processing package shotwell (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of yad:
 yad depends on libwebkitgtk-3.0-0 (>= 1.7.92); however:
  Package libwebkitgtk-3.0-0:amd64 is not configured yet.

dpkg: error processing package yad (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of y-ppa-manager:
 y-ppa-manager depends on yad (>= 0.36.0); however:
  Package yad is not configured yet.

dpkg: error processing package y-ppa-manager (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libwayland-server0:amd64
 libgbm1:amd64
 libegl1-mesa:amd64
 libwayland-egl1-mesa:amd64
 libwebkit2gtk-4.0-37:amd64
 gir1.2-webkit2-4.0:amd64
 libqt5gui5:amd64
 libqt5widgets5:amd64
 libqt5opengl5:amd64
 libqt5printsupport5:amd64
 libwebkit2gtk-4.0-37-gtk2:amd64
 libwebkitgtk-3.0-0:amd64
 qml-module-ubuntu-web:amd64
 signon-ui-x11
 signon-ui
 webbrowser-app
 webapp-container
 xserver-xorg-core
 xserver-xorg-video-amdgpu
 xserver-xorg-video-intel
 appmenu-qt5
 shotwell
 yad
 y-ppa-manager
E: Sub-process /usr/bin/dpkg returned an error code (1)

What can I do about this?

2
  • Please try sudo apt install --reinstall libwayland-server0 – Charles Green Sep 29 '17 at 13:01
  • What have you been doing to your system?? APT is really messed up – Zanna Sep 29 '17 at 19:40