2

I'm unable to launch google-chrome-stable. This is the error I am getting:

[4604:4640:0929/093415.646539:FATAL:nss_util.cc(632)] NSS_VersionCheck("3.26") failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.
Aborted (core dumped)

People suggest if you are running an older version of ubuntu it won't work but I am on 16.04

I have been looking online and have tried all the different suggestions e.g. to perform security updates.

$ sudo apt-get update
$ sudo apt-get dist-upgrade
$ sudo apt-get install libnss3

However if I run $ apt-cache policy libnss3 I get the following:

libnss3:
  Installed: 2:3.21-1ubuntu4
  Candidate: 2:3.21-1ubuntu4
  Version table:
 *** 2:3.21-1ubuntu4 500
        500 http://de.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status

EDIT

After running sudo apt update && sudo apt full-upgrade output related to google chrome:

Ign:19 http://dl.google.com/linux/chrome/deb stable InRelease             
Get:20 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Hit:21 http://dl.google.com/linux/chrome/deb stable Release
Fetched 102 kB in 7s (13.9 kB/s)                               
Reading package lists... Done
Building dependency tree       
Reading state information... Done
10 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: http://repo.acestream.org/ubuntu/dists/trusty/InRelease: Signature by key E1254F21D636B7EFDE41D2AF50E2BCF0E3805CD8 uses weak digest algorithm (SHA1)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  google-chrome-stable
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/65.3 MB of archives.
After this operation, 146 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 403416 files and directories currently installed.)
Preparing to unpack .../google-chrome-stable_61.0.3163.100-1_amd64.deb ...
Unpacking google-chrome-stable (61.0.3163.100-1) over (61.0.3163.79-1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up google-chrome-stable (61.0.3163.100-1) ...

I am still seeing the same error message after this after a restart

  • I would suggest Google Chrome itself needs updating. How did you install it? – user692175 Sep 29 '17 at 9:08
  • @MichaelBay I downloaded the deb package from here google.com/chrome/browser and installed using sudo dpkg -i google-chrome-stable_current_amd64.deb – tester123 Sep 29 '17 at 9:12
  • OK, does sudo apt update (yes, in any 16,04+ use apt instead of apt-get and full-upgrade instead of dist-upgrade) produce any error? Please try running again sudo apt update && sudo apt full-upgrade, edit and post the full error messages, if any. – user692175 Sep 29 '17 at 9:17
  • It shouldn't need a restart (but try it anyway). – user692175 Sep 29 '17 at 9:27
  • 1
3

just try below commands on your ubuntu machine.

sudo apt-get install --reinstall libnss3

It will fix your issue with libnss3 package

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.