2
Err:1 http://us.archive.ubuntu.com/ubuntu zesty-updates/main amd64 libqt5test5 amd64 5.7.1+dfsg-2ubuntu4~1.17.04.1
  403  Forbidden [IP: 91.189.91.26 80]
E: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/q/qtbase-opensource-src/libqt5test5_5.7.1+dfsg-2ubuntu4~1.17.04.1_amd64.deb  403  Forbidden [IP: 91.189.91.26 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

marked as duplicate by pa4080, karel, Eric Carvalho, Mark Kirby, David Foerster Sep 30 '17 at 0:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • did you try what it tells you to try? – spacelander Sep 29 '17 at 7:21
  • 1
    Have you tried to select another repository server to download from ? THe error you get says "403 Forbidden", that is the server denying you access. – Soren A Sep 29 '17 at 7:30
  • Yes i tried apt -get update and it dose not work. – Adon Naaman Sep 29 '17 at 7:33
  • yes i have these : archive.canonical.com/ubuntu dl.google.com/linux/chrome/deb and i do not know how to add more and which one i should add – Adon Naaman Sep 29 '17 at 7:35
3

Yesterday I experienced the same problem with the bg. mirror on my 2 computers with Ubuntu. I tried to open http://bg.archive.ubuntu.com from the browser and received an error. Then I tried http://archive.ubuntu.com and I saw it's working.

So the solution was temporary switching from the local repository bg.archive.ubuntu.com to the central repository archive.ubuntu.com by editing of the file /etc/apt/sources.list. You can do this from the command line by using sed command in this way:

sudo sed 's/bg.archive.ubuntu.com/archive.ubuntu.com/g' /etc/apt/sources.list -i.bak

Later you can restore the original state by the command:

sudo mv /etc/apt/sources.list.bak /etc/apt/sources.list
  • how you edit it because it written that i don't have permissions – Adon Naaman Sep 29 '17 at 7:46
  • @AdonNaaman: You should use sudo command to gain root access to the file: sudo nano /path/to/file/, or sudo -H gedit /path/to/file, or use the command from the answer, etc. – pa4080 Sep 29 '17 at 7:52
  • 2
    And you can change as well at System Settngs > Software & Updates ("Software Properties" in 16.04) – user692175 Sep 29 '17 at 9:25
  • i did it and the same result – Adon Naaman Sep 29 '17 at 11:06
  • 1
    It solved until now after i write this command : sudo apt-get clean – Adon Naaman Sep 29 '17 at 11:21
-1

I have gotten that problem before and it was the Firewall/Content Filtering appliance that was blocking access to some of my repo addresses. Not sure if that is a possibility for you.

I whitelisted my linux host on the Firewall/Content Filtering appliance so that it would have unrestricted access outbound.

  • and how you solved it – Adon Naaman Sep 29 '17 at 7:38
  • I whitelisted my linux host on the Firewall/Content Filtering appliance so that it would have unrestricted access outbound – Nicholai Cornilliac Sep 29 '17 at 7:41
  • If you are being blocked by a firewall ALL repos will fail, not just ONE. – Soren A Sep 29 '17 at 10:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.